packagegroup-sdk-target.bb 924 B

12345678910111213141516171819202122232425262728
  1. SUMMARY = "Packages required for a target (on-device) SDK"
  2. LICENSE = "MIT"
  3. LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
  4. PR = "r1"
  5. inherit packagegroup
  6. RPROVIDES_${PN} += "packagegroup-native-sdk"
  7. RREPLACES_${PN} += "packagegroup-native-sdk"
  8. RCONFLICTS_${PN} += "packagegroup-native-sdk"
  9. RDEPENDS_${PN} = "gcc-symlinks g++-symlinks cpp cpp-symlinks \
  10. binutils-symlinks \
  11. perl-modules \
  12. flex flex-dev \
  13. bison \
  14. gawk \
  15. sed \
  16. grep \
  17. autoconf automake \
  18. make \
  19. patch diffstat diffutils \
  20. libstdc++-dev \
  21. libtool libtool-dev \
  22. pkgconfig"
  23. # usefull, but not in oe-core/meta-oe yet: patchutils
  24. RRECOMMENDS_${PN} = " g77-symlinks gfortran-symlinks"