libconfig-autoconf-perl_0.319.bb 1.6 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright (C) 2020 Jens Rehsack <sno@netbsd.org>
  2. # Released under the MIT license (see COPYING.MIT for the terms)
  3. SUMMARY = "A module to implement some of AutoConf macros in pure perl"
  4. DESCRIPTION = "Config::AutoConf is intended to provide the same opportunities to Perl \
  5. developers as GNU Autoconf <http://www.gnu.org/software/autoconf/> does for \
  6. Shell developers."
  7. HOMEPAGE= "https://metacpan.org/release/Config-AutoConf"
  8. SECTION = "libs"
  9. LICENSE = "Artistic-1.0 | GPL-1.0+"
  10. LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Artistic-1.0;md5=cda03bbdc3c1951996392b872397b798 \
  11. file://${COMMON_LICENSE_DIR}/GPL-1.0;md5=e9e36a9de734199567a4d769498f743d"
  12. SRC_URI = "${CPAN_MIRROR}/authors/id/R/RE/REHSACK/Config-AutoConf-${PV}.tar.gz"
  13. SRC_URI[md5sum] = "eeeab8cc93eef7dd2e2c343ecdf247b7"
  14. SRC_URI[sha256sum] = "304f66cc2653264c0fe127d21669e86d3d18cd72f2574d8f5131beec31a0a33e"
  15. RDEPENDS_${PN} += "libcapture-tiny-perl"
  16. RDEPENDS_${PN} += "perl-module-base"
  17. RDEPENDS_${PN} += "perl-module-carp"
  18. RDEPENDS_${PN} += "perl-module-config"
  19. RDEPENDS_${PN} += "perl-module-constant"
  20. RDEPENDS_${PN} += "perl-module-file-basename"
  21. RDEPENDS_${PN} += "perl-module-file-spec"
  22. RDEPENDS_${PN} += "perl-module-file-temp"
  23. RDEPENDS_${PN} += "perl-module-extutils-cbuilder"
  24. RDEPENDS_${PN} += "perl-module-extutils-cbuilder-platform-unix"
  25. RDEPENDS_${PN} += "perl-module-scalar-util"
  26. RDEPENDS_${PN} += "perl-module-strict"
  27. RDEPENDS_${PN} += "perl-module-text-parsewords"
  28. RDEPENDS_${PN} += "perl-module-warnings"
  29. RRECOMMENDS_${PN} += "libfile-slurper-perl"
  30. S = "${WORKDIR}/Config-AutoConf-${PV}"
  31. inherit cpan ptest-perl
  32. BBCLASSEXTEND = "native nativesdk"