nbench-byte_2.2.3.bb 866 B

12345678910111213141516171819202122232425
  1. DESCRIPTION = "BYTE Magazine's native benchmarks (also called BYTEmark) \
  2. designed to expose the capabilities of a system's CPU, FPU, \
  3. and memory system."
  4. HOMEPAGE = "http://www.tux.org/~mayer/linux/"
  5. LICENSE = "nbench-byte"
  6. LIC_FILES_CHKSUM = "file://README;beginline=57;endline=66;md5=020ef579f8fa5746b7e307a54707834f"
  7. SECTION = "console/utils"
  8. SRC_URI = "http://www.tux.org/~mayer/linux/${BP}.tar.gz \
  9. file://nbench_32bits.patch \
  10. file://Makefile-add-more-dependencies-to-pointer.h.patch"
  11. SRC_URI[md5sum] = "285dfab361080759d477ea1fe7d3093a"
  12. SRC_URI[sha256sum] = "723dd073f80e9969639eb577d2af4b540fc29716b6eafdac488d8f5aed9101ac"
  13. TARGET_CC_ARCH += "${CFLAGS} ${LDFLAGS}"
  14. do_compile() {
  15. oe_runmake
  16. }
  17. do_install () {
  18. install -d ${D}${bindir}
  19. install -m 0644 NNET.DAT ${D}${bindir}/
  20. install -m 0755 nbench ${D}${bindir}/
  21. }