gegl_0.4.26.bb 2.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960
  1. SUMMARY = "GEGL (Generic Graphics Library) is a graph based image processing framework"
  2. LICENSE = "GPLv3"
  3. LIC_FILES_CHKSUM = "file://COPYING;md5=f1a8bfcbc85304df454b65d378b299c7"
  4. DEPENDS = " \
  5. intltool-native \
  6. babl \
  7. glib-2.0 \
  8. pango \
  9. cairo \
  10. expat \
  11. zlib \
  12. \
  13. json-glib \
  14. "
  15. GNOMEBASEBUILDCLASS = "meson"
  16. inherit features_check gnomebase vala gobject-introspection
  17. REQUIRED_DISTRO_FEATURES = "x11"
  18. SHPV = "${@gnome_verdir("${PV}")}"
  19. SRC_URI = " \
  20. https://download.gimp.org/pub/${BPN}/${SHPV}/${BP}.tar.xz \
  21. file://0001-meson.build-Give-note-if-sdl2-was-found.patch \
  22. "
  23. SRC_URI[sha256sum] = "0f371e2ed2b92162fefd3dde743e648ca08a6a1b2b05004867fbddc7e211e424"
  24. PACKAGECONFIG ??= "gexiv2 jpeg libpng librsvg sdl2"
  25. PACKAGECONFIG_class-native = "libpng librsvg"
  26. PACKAGECONFIG[jasper] = "-Djasper=enabled,-Djasper=disabled,jasper"
  27. PACKAGECONFIG[gexiv2] = "-Dgexiv2=enabled,-Dgexiv2=disabled,gexiv2"
  28. PACKAGECONFIG[graphviz] = "-Dgraphviz=enabled,-Dgraphviz=disabled,graphviz"
  29. PACKAGECONFIG[jpeg] = "-Dlibjpeg=enabled,-Dlibjpeg=disabled,jpeg"
  30. PACKAGECONFIG[lcms] = "-Dlcms=enabled,-Dlcms=disabled,lcms"
  31. PACKAGECONFIG[libav] = "-Dlibav=enabled,-Dlibav=disabled,libav"
  32. PACKAGECONFIG[libpng] = "-Dlibpng=enabled,-Dlibpng=disabled,libpng"
  33. PACKAGECONFIG[librsvg] = "-Dlibrsvg=enabled,-Dlibrsvg=disabled,librsvg"
  34. PACKAGECONFIG[sdl] = "-Dsdl1=enabled,-Dsdl1=disabled,virtual/libsdl"
  35. PACKAGECONFIG[sdl2] = "-Dsdl2=enabled,-Dsdl2=disabled,virtual/libsdl2"
  36. PACKAGECONFIG[tiff] = "-Dlibtiff=enabled,-Dlibtiff=disabled,tiff"
  37. PACKAGECONFIG[webp] = "-Dwebp=enabled,-Dwebp=disabled,webp"
  38. # There are a couple of non-symlink .so files installed into libdir, which need to go into main package
  39. FILES_${PN} += " \
  40. ${libdir}/*.so \
  41. ${libdir}/gegl-${SHPV}/*.json \
  42. ${libdir}/gegl-${SHPV}/*.so \
  43. "
  44. FILES_SOLIBSDEV = "${libdir}/libgegl-${SHPV}${SOLIBSDEV}"
  45. # Fails to build with thumb-1 (qemuarm)
  46. # gegl-0.2.0/operations/common/matting-global.c: In function 'matting_process':
  47. # gegl-0.2.0/operations/common/matting-global.c:463:1: internal compiler error: in patch_jump_insn, at cfgrtl.c:1275
  48. ARM_INSTRUCTION_SET = "arm"
  49. BBCLASSEXTEND = "native"