fluentbit_1.3.5.bb 1.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263
  1. SUMMARY = "Fast Log processor and Forwarder"
  2. DESCRIPTION = "Fluent Bit is a data collector, processor and \
  3. forwarder for Linux. It supports several input sources and \
  4. backends (destinations) for your data. \
  5. "
  6. HOMEPAGE = "http://fluentbit.io"
  7. BUGTRACKER = "https://github.com/fluent/fluent-bit/issues"
  8. LICENSE = "Apache-2.0"
  9. LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
  10. SECTION = "net"
  11. SRC_URI = "http://fluentbit.io/releases/1.3/fluent-bit-${PV}.tar.gz \
  12. file://jemalloc.patch \
  13. file://cross-build-init-system-detection.patch \
  14. file://builtin-nan.patch \
  15. file://0001-ppc-Fix-signature-for-co_create-API.patch \
  16. "
  17. SRC_URI[md5sum] = "6eae6dfd0a874e5dd270c36e9c68f747"
  18. SRC_URI[sha256sum] = "e037c76c89269c8dc4027a08e442fefd2751b0f1e0f9c38f9a4b12d781a9c789"
  19. S = "${WORKDIR}/fluent-bit-${PV}"
  20. DEPENDS = "zlib bison-native flex-native"
  21. DEPENDS_append_libc-musl = " fts "
  22. INSANE_SKIP_${PN}-dev += "dev-elf"
  23. LTO = ""
  24. # Use CMake 'Unix Makefiles' generator
  25. OECMAKE_GENERATOR ?= "Unix Makefiles"
  26. # Fluent Bit build options
  27. # ========================
  28. # Host related setup
  29. EXTRA_OECMAKE += "-DGNU_HOST=${HOST_SYS} -DFLB_ALL=ON -DFLB_TD=1"
  30. # Disable LuaJIT and filter_lua support
  31. EXTRA_OECMAKE += "-DFLB_LUAJIT=Off -DFLB_FILTER_LUA=Off "
  32. # Disable Library and examples
  33. EXTRA_OECMAKE += "-DFLB_SHARED_LIB=Off -DFLB_EXAMPLES=Off "
  34. EXTRA_OECMAKE += "${@bb.utils.contains('DISTRO_FEATURES','systemd','-DFLB_SYSTEMD=On','',d)}"
  35. EXTRA_OECMAKE_append_riscv64 = " -DFLB_DEPS='atomic'"
  36. EXTRA_OECMAKE_append_riscv32 = " -DFLB_DEPS='atomic'"
  37. # Kafka Output plugin (disabled by default): note that when
  38. # enabling Kafka output plugin, the backend library librdkafka
  39. # requires 'openssl' as a dependency.
  40. #
  41. # DEPENDS += "openssl "
  42. # EXTRA_OECMAKE += "-DFLB_OUT_KAFKA=On "
  43. inherit cmake systemd
  44. CFLAGS += "-fcommon"
  45. SYSTEMD_SERVICE_${PN} = "td-agent-bit.service"
  46. TARGET_CC_ARCH_append = " ${SELECTED_OPTIMIZATION}"