whetstone_1.2.bb 666 B

1234567891011121314151617181920
  1. DESCRIPTION = "Whetstone benchmark is a synthetic benchmark for evaluating the performance of computers"
  2. SUMMARY = "CPU benchmark to measure floating point performance"
  3. LICENSE = "PD"
  4. LIC_FILES_CHKSUM ="file://${WORKDIR}/whetstone.c;beginline=1;endline=52;md5=c795edc15e7e1d92ca8f88ad718449f5"
  5. SRC_URI = "http://www.netlib.org/benchmark/whetstone.c"
  6. SRC_URI[md5sum] = "d8eb2cd7104bb5a12d614ac6d3f1f9fb"
  7. SRC_URI[sha256sum] = "333e4ceca042c146f63eec605573d16ae8b07166cbc44a17bec1ea97c6f1efbf"
  8. S = "${WORKDIR}"
  9. do_compile () {
  10. ${CC} ${CFLAGS} ${LDFLAGS} -Ofast -o whetstone whetstone.c -lm
  11. }
  12. do_install () {
  13. install -Dm 0755 whetstone ${D}${bindir}/whetstone
  14. }