gnuplot_5.2.8.bb 2.6 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071
  1. SUMMARY = "Gnuplot is a portable command-line driven graphing utility"
  2. DESCRIPTION = "Gnuplot is a portable command-line driven interactive datafile \
  3. (text or binary) and function plotting utility."
  4. HOMEPAGE = "http://www.gnuplot.info/"
  5. SECTION = "console/scientific"
  6. LICENSE = "gnuplot"
  7. LIC_FILES_CHKSUM = "file://Copyright;md5=243a186fc2fd3b992125d60d5b1bab8f"
  8. DEPENDS = "${BPN}-native virtual/libx11 gd readline"
  9. inherit autotools features_check
  10. # depends on virtual/libx11
  11. REQUIRED_DISTRO_FEATURES = "x11"
  12. SRC_URI = "${SOURCEFORGE_MIRROR}/gnuplot/${BP}.tar.gz;name=archive \
  13. http://www.mneuroth.de/privat/zaurus/qtplot-0.2.tar.gz;name=qtplot \
  14. file://gnuplot.desktop \
  15. file://gnuplot.png \
  16. "
  17. SRC_URI_append_class-target = " \
  18. file://0002-do-not-build-demos.patch \
  19. file://0003-Use-native-tools-to-build-docs.patch \
  20. file://0004-Add-configure-option-to-find-qt5-native-tools.patch \
  21. "
  22. SRC_URI[archive.md5sum] = "2df8767c7399bee57a96296d46b4d5fb"
  23. SRC_URI[archive.sha256sum] = "60a6764ccf404a1668c140f11cc1f699290ab70daa1151bb58fed6139a28ac37"
  24. SRC_URI[qtplot.md5sum] = "0a481885a496092c77eb4017540b5cf6"
  25. SRC_URI[qtplot.sha256sum] = "6df317183ff62cc82f3dcf88207a267cd6478cb5147f55d7530c94f1ad5f4132"
  26. # for building docs (they deserve it) we need *doc2* tools native
  27. BBCLASSEXTEND = "native"
  28. DEPENDS_class-native = "readline-native"
  29. PACKAGECONFIG_class-native = ""
  30. SRC_URI_append_class-native = " file://0001-reduce-build-to-conversion-tools-for-native-build.patch"
  31. do_install_class-native() {
  32. install -d ${D}${bindir}
  33. install ${B}/docs/*doc* ${D}${bindir}
  34. rm ${D}${bindir}/*.o
  35. }
  36. PACKAGECONFIG ??= "cairo"
  37. PACKAGECONFIG[cairo] = "--with-cairo,--without-cairo,cairo pango"
  38. PACKAGECONFIG[lua] = "--with-lua,--without-lua,lua"
  39. PACKAGECONFIG[qt5] = "--with-qt --with-qt5nativesysroot=${STAGING_DIR_NATIVE},--without-qt,qtbase-native qtbase qtsvg qttools-native"
  40. EXTRA_OECONF = "--with-readline=${STAGING_LIBDIR}/.. \
  41. --without-tutorial \
  42. --disable-wxwidgets"
  43. do_compile_prepend() {
  44. install -m 0644 ${WORKDIR}/qtplot-0.2/qtopia.trm ${S}/term/
  45. }
  46. do_install_append_class-target() {
  47. install -d ${D}${datadir}/applications/
  48. install -m 0644 ${WORKDIR}/gnuplot.desktop ${D}${datadir}/applications/
  49. install -d ${D}${datadir}/pixmaps/
  50. install -m 0644 ${WORKDIR}/gnuplot.png ${D}${datadir}/pixmaps/
  51. }
  52. PACKAGES =+ "${PN}-x11"
  53. RPROVIDES_${PN}-dbg += "${PN}-x11-dbg"
  54. DESCRIPTION_${PN}-x11 = "X11 display terminal for Gnuplot."
  55. SECTION_${PN}-x11 = "x11/scientific"
  56. FILES_${PN}-x11 = "${libexecdir} ${datadir}/applications ${datadir}/pixmaps ${libdir}/X11 "
  57. FILES_${PN} += "${datadir}/texmf"