zsh_5.4.2.bb 2.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465
  1. SUMMARY = "UNIX Shell similar to the Korn shell"
  2. DESCRIPTION = "Zsh is a shell designed for interactive use, although it is also a \
  3. powerful scripting language. Many of the useful features of bash, \
  4. ksh, and tcsh were incorporated into zsh; many original features were added."
  5. HOMEPAGE = "http://www.zsh.org"
  6. SECTION = "base/shell"
  7. LICENSE = "zsh"
  8. LIC_FILES_CHKSUM = "file://LICENCE;md5=1a4c4cda3e8096d2fd483ff2f4514fec"
  9. DEPENDS = "ncurses bison-native libcap libpcre gdbm groff-native"
  10. SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz"
  11. SRC_URI[md5sum] = "dfe156fd69b0d8d1745ecf6d6e02e047"
  12. SRC_URI[sha256sum] = "957bcdb2c57f64c02f673693ea5a7518ef24b6557aeb3a4ce222cefa6d74acc9"
  13. inherit autotools gettext update-alternatives
  14. EXTRA_OECONF = " \
  15. --bindir=${base_bindir} \
  16. --enable-etcdir=${sysconfdir} \
  17. --enable-fndir=${datadir}/${PN}/${PV}/functions \
  18. --enable-site-fndir=${datadir}/${PN}/site-functions \
  19. --with-term-lib='ncursesw ncurses' \
  20. --with-tcsetpgrp \
  21. --enable-cap \
  22. --enable-multibyte \
  23. --disable-gdbm \
  24. --disable-dynamic \
  25. zsh_cv_shared_environ=yes \
  26. "
  27. # Configure respects --bindir from EXTRA_OECONF, but then Src/Makefile will read bindir from environment
  28. export bindir="${base_bindir}"
  29. EXTRA_OEMAKE = "-e MAKEFLAGS="
  30. ALTERNATIVE_${PN} = "sh"
  31. ALTERNATIVE_LINK_NAME[sh] = "${base_bindir}/sh"
  32. ALTERNATIVE_TARGET[sh] = "${base_bindir}/${BPN}"
  33. ALTERNATIVE_PRIORITY = "100"
  34. export AUTOHEADER = "true"
  35. do_configure () {
  36. gnu-configize --force ${S}
  37. oe_runconf
  38. }
  39. do_install_append () {
  40. rm -fr ${D}/usr/share
  41. rmdir --ignore-fail-on-non-empty ${D}/usr
  42. }
  43. pkg_postinst_${PN} () {
  44. touch $D${sysconfdir}/shells
  45. grep -q "bin/zsh" $D${sysconfdir}/shells || echo /bin/zsh >> $D${sysconfdir}/shells
  46. grep -q "bin/sh" $D${sysconfdir}/shells || echo /bin/sh >> $D${sysconfdir}/shells
  47. }
  48. FILES_${PN}-dbg += "\
  49. ${libdir}/${PN}/${PV}/${PN}/.debug/*.so \
  50. ${libdir}/${PN}/${PV}/${PN}/db/.debug/*.so \
  51. ${libdir}/${PN}/${PV}/${PN}/net/.debug/*.so \
  52. "