imagemagick_7.0.10.bb 4.6 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091
  1. SUMMARY = "ImageMagick is an image conversion toolkit"
  2. SECTION = "console/utils"
  3. HOMEPAGE = "https://www.imagemagick.org/"
  4. DESCRIPTION = "ImageMagick is a collection of tools for displaying, converting, and \
  5. editing raster and vector image files. It can read and write over 200 image file formats."
  6. LICENSE = "ImageMagick"
  7. LIC_FILES_CHKSUM = "file://LICENSE;md5=41b4fa9af60c88e61484b02c0561181a \
  8. file://NOTICE;md5=a2aa6e41f8a40700196a9ce301693e34"
  9. # FIXME: There are many more checked libraries. All should be added or explicitly disabled to get consistent results.
  10. DEPENDS = "lcms bzip2 jpeg libpng tiff zlib fftw freetype libtool"
  11. BASE_PV := "${PV}"
  12. PV .= "_25"
  13. SRC_URI = "git://github.com/ImageMagick/ImageMagick.git "
  14. SRCREV = "8b4e00829eb84d4e7b4da11acf1f98f1e8166e5b"
  15. S = "${WORKDIR}/git"
  16. inherit autotools pkgconfig update-alternatives
  17. # xml disabled because it's using xml2-config --prefix to determine prefix which returns just /usr with our libxml2
  18. # if someone needs xml support then fix it first
  19. EXTRA_OECONF = "--program-prefix= --program-suffix=.im7 --without-perl --disable-openmp --without-xml --disable-opencl"
  20. CACHED_CONFIGUREVARS = "ac_cv_sys_file_offset_bits=yes"
  21. PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
  22. PACKAGECONFIG[graphviz] = "--with-gvc,--without-gvc,graphviz"
  23. PACKAGECONFIG[jp2] = "--with-jp2,,jasper"
  24. PACKAGECONFIG[lzma] = "--with-lzma,--without-lzma,xz"
  25. PACKAGECONFIG[openjpeg] = "--with-openjp2,--without-openjp2,openjpeg"
  26. PACKAGECONFIG[pango] = "--with-pango,--without-pango,pango cairo"
  27. PACKAGECONFIG[rsvg] = "--with-rsvg,--without-rsvg,librsvg"
  28. PACKAGECONFIG[tcmalloc] = "--with-tcmalloc=yes,--with-tcmalloc=no,gperftools"
  29. PACKAGECONFIG[webp] = "--with-webp,--without-webp,libwebp"
  30. PACKAGECONFIG[wmf] = "--with-wmf,--without-wmf,libwmf"
  31. PACKAGECONFIG[x11] = "--with-x,--without-x,virtual/libx11 libxext libxt"
  32. FILES_${PN} += "${libdir}/ImageMagick-${BASE_PV}/config-Q16* \
  33. ${datadir}/ImageMagick-7"
  34. FILES_${PN}-dev += "${libdir}/ImageMagick-${BASE_PV}/modules-Q16/*/*.a"
  35. FILES_${PN}-dbg += "${libdir}/ImageMagick-${BASE_PV}/modules-Q16/*/.debug/*"
  36. BBCLASSEXTEND = "native"
  37. ALTERNATIVE_PRIORITY = "100"
  38. ALTERNATIVE_${PN} = "animate compare composite conjure convert display \
  39. identify import magick-script mogrify montage stream"
  40. ALTERNATIVE_TARGET[animate] = "${bindir}/animate.im7"
  41. ALTERNATIVE_TARGET[compare] = "${bindir}/compare.im7"
  42. ALTERNATIVE_TARGET[composite] = "${bindir}/composite.im7"
  43. ALTERNATIVE_TARGET[conjure] = "${bindir}/conjure.im7"
  44. ALTERNATIVE_TARGET[convert] = "${bindir}/convert.im7"
  45. ALTERNATIVE_TARGET[display] = "${bindir}/display.im7"
  46. ALTERNATIVE_TARGET[identify] = "${bindir}/identify.im7"
  47. ALTERNATIVE_TARGET[import] = "${bindir}/import.im7"
  48. ALTERNATIVE_TARGET[magick-script] = "${bindir}/magick-script.im7"
  49. ALTERNATIVE_TARGET[mogrify] = "${bindir}/mogrify.im7"
  50. ALTERNATIVE_TARGET[montage] = "${bindir}/montage.im7"
  51. ALTERNATIVE_TARGET[stream] = "${bindir}/stream.im7"
  52. ALTERNATIVE_${PN}-doc = "animate.1 compare.1 composite.1 conjure.1 \
  53. convert.1 display.1 identify.1 import.1 magick-script.1 mogrify.1 montage.1 stream.1"
  54. ALTERNATIVE_LINK_NAME[animate.1] = "${mandir}/man1/animate.1"
  55. ALTERNATIVE_TARGET[animate.1] = "${mandir}/man1/animate.im7.1"
  56. ALTERNATIVE_LINK_NAME[compare.1] = "${mandir}/man1/compare.1"
  57. ALTERNATIVE_TARGET[compare.1] = "${mandir}/man1/compare.im7.1"
  58. ALTERNATIVE_LINK_NAME[composite.1] = "${mandir}/man1/composite.1"
  59. ALTERNATIVE_TARGET[composite.1] = "${mandir}/man1/composite.im7.1"
  60. ALTERNATIVE_LINK_NAME[conjure.1] = "${mandir}/man1/conjure.1"
  61. ALTERNATIVE_TARGET[conjure.1] = "${mandir}/man1/conjure.im7.1"
  62. ALTERNATIVE_LINK_NAME[convert.1] = "${mandir}/man1/convert.1"
  63. ALTERNATIVE_TARGET[convert.1] = "${mandir}/man1/convert.im7.1"
  64. ALTERNATIVE_LINK_NAME[display.1] = "${mandir}/man1/display.1"
  65. ALTERNATIVE_TARGET[display.1] = "${mandir}/man1/display.im7.1"
  66. ALTERNATIVE_LINK_NAME[identify.1] = "${mandir}/man1/identify.1"
  67. ALTERNATIVE_TARGET[identify.1] = "${mandir}/man1/identify.im7.1"
  68. ALTERNATIVE_LINK_NAME[import.1] = "${mandir}/man1/import.1"
  69. ALTERNATIVE_TARGET[import.1] = "${mandir}/man1/import.im7.1"
  70. ALTERNATIVE_LINK_NAME[magick-script.1] = "${mandir}/man1/magick-script.1"
  71. ALTERNATIVE_TARGET[magick-script.1] = "${mandir}/man1/magick-script.im7.1"
  72. ALTERNATIVE_LINK_NAME[mogrify.1] = "${mandir}/man1/mogrify.1"
  73. ALTERNATIVE_TARGET[mogrify.1] = "${mandir}/man1/mogrify.im7.1"
  74. ALTERNATIVE_LINK_NAME[montage.1] = "${mandir}/man1/montage.1"
  75. ALTERNATIVE_TARGET[montage.1] = "${mandir}/man1/montage.im7.1"
  76. ALTERNATIVE_LINK_NAME[stream.1] = "${mandir}/man1/stream.1"
  77. ALTERNATIVE_TARGET[stream.1] = "${mandir}/man1/stream.im7.1"