dash_0.5.11.3.bb 951 B

123456789101112131415161718192021222324252627
  1. SUMMARY = "Small and fast POSIX-compliant shell"
  2. HOMEPAGE = "http://gondor.apana.org.au/~herbert/dash/"
  3. SECTION = "System Environment/Shells"
  4. LICENSE = "BSD & GPLv2+"
  5. LIC_FILES_CHKSUM = "file://COPYING;md5=b5262b4a1a1bff72b48e935531976d2e"
  6. inherit autotools update-alternatives
  7. SRC_URI = "http://gondor.apana.org.au/~herbert/${BPN}/files/${BP}.tar.gz"
  8. SRC_URI[md5sum] = "c7016b513f701d88c70b3082eb183581"
  9. SRC_URI[sha256sum] = "62b9f1676ba6a7e8eaec541a39ea037b325253240d1f378c72360baa1cbcbc2a"
  10. EXTRA_OECONF += "--bindir=${base_bindir}"
  11. ALTERNATIVE_${PN} = "sh"
  12. ALTERNATIVE_LINK_NAME[sh] = "${base_bindir}/sh"
  13. ALTERNATIVE_TARGET[sh] = "${base_bindir}/dash"
  14. ALTERNATIVE_PRIORITY = "10"
  15. pkg_postinst_${PN} () {
  16. grep -q "^${base_bindir}/dash$" $D${sysconfdir}/shells || echo ${base_bindir}/dash >> $D${sysconfdir}/shells
  17. }
  18. pkg_postrm_${PN} () {
  19. printf "$(grep -v "^${base_bindir}/dash$" $D${sysconfdir}/shells)\n" > $D${sysconfdir}/shells
  20. }