snappy_1.1.8.bb 1020 B

12345678910111213141516171819202122232425
  1. #
  2. # Copyright (C) 2014 Wind River Systems, Inc.
  3. # Released under the BSD-3-Clause license (see COPYING.BSD-3 for the terms)
  4. #
  5. SUMMARY = "A compression/decompression library"
  6. DESCRIPTION = "Snappy is a fast data compression and decompression library \
  7. It was designed to be very fast and stable, but not to achieve a high \
  8. compression ratio."
  9. LICENSE = "BSD-3-Clause"
  10. LIC_FILES_CHKSUM = "file://COPYING;md5=f62f3080324a97b3159a7a7e61812d0c"
  11. SRC_URI = "https://src.fedoraproject.org/repo/pkgs/snappy/snappy-1.1.8.tar.gz/sha512/efe18ff1b3edda1b4b6cefcbc6da8119c05d63afdbf7a784f3490353c74dced76baed7b5f1aa34b99899729192b9d657c33c76de4b507a51553fa8001ae75c1c/snappy-1.1.8.tar.gz"
  12. SRC_URI[md5sum] = "70e48cba7fecf289153d009791c9977f"
  13. SRC_URI[sha256sum] = "16b677f07832a612b0836178db7f374e414f94657c138e6993cbfc5dcc58651f"
  14. inherit cmake pkgconfig
  15. PACKAGECONFIG ??= ""
  16. PACKAGECONFIG[lzo] = "-DHAVE_LIBLZO2=1,-DHAVE_LIBLZO2=0,lzo,"
  17. TARGET_CFLAGS += "-fPIC"
  18. EXTRA_OECMAKE += '-DBUILD_SHARED_LIBS="ON" \
  19. '