caps_0.9.26.bb 788 B

123456789101112131415161718192021222324252627
  1. DESCRIPTION = "The CAPS Audio Plugin Suite - LADSPA plugin suite"
  2. HOMEPAGE = "http://quitte.de/dsp/caps.html"
  3. LICENSE = "GPL-3"
  4. LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
  5. SRC_URI = "http://quitte.de/dsp/${BPN}_${PV}.tar.bz2 \
  6. file://0001-basic.h-Use-c99-supported-stdint-types.patch \
  7. file://append_ldflags.patch \
  8. "
  9. SRC_URI[md5sum] = "36b30c7c7db2d2bc5f4f54077e97b5ee"
  10. SRC_URI[sha256sum] = "e7496c5bce05abebe3dcb635926153bbb58a9337a6e423f048d3b61d8a4f98c9"
  11. EXTRA_OEMAKE = " \
  12. CC='${CXX}' \
  13. CFLAGS='${CFLAGS} -ffast-math -funroll-loops -fPIC -DPIC' \
  14. ARCH='' \
  15. "
  16. do_compile() {
  17. oe_runmake all
  18. }
  19. do_install() {
  20. install -Dm 0644 caps.so ${D}${libdir}/ladspa/caps.so
  21. }
  22. FILES_${PN} = "${libdir}/ladspa/"