gd_2.3.0.bb 1.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. SUMMARY = "gd is a library used to create PNG, JPEG, or WBMP images"
  2. DESCRIPTION = "The gd graphics library allows your code to quickly draw images \
  3. complete with lines, arcs, text, multiple colors, cut and paste from other \
  4. images, and flood fills, and to write out the result as a PNG or JPEG file. \
  5. This is particularly useful in Web applications, where PNG and JPEG are two \
  6. of the formats accepted for inline images by most browsers. Note that gd is not \
  7. a paint program."
  8. HOMEPAGE = "http://libgd.github.io/"
  9. SECTION = "libs"
  10. LICENSE = "GD"
  11. LIC_FILES_CHKSUM = "file://COPYING;md5=8e5bc8627b9494741c905d65238c66b7"
  12. DEPENDS = "freetype libpng jpeg zlib tiff"
  13. SRC_URI = "git://github.com/libgd/libgd.git;branch=master \
  14. "
  15. SRCREV = "b079fa06223c3ab862c8f0eea58a968727971988"
  16. S = "${WORKDIR}/git"
  17. inherit autotools binconfig gettext pkgconfig
  18. EXTRA_OECONF += " --disable-rpath \
  19. --with-jpeg=${STAGING_LIBDIR}/.. \
  20. --with-freetype=yes \
  21. --without-fontconfig \
  22. --without-webp \
  23. --without-xpm \
  24. --without-x \
  25. "
  26. EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"'
  27. DEBUG_OPTIMIZATION_append = " -Wno-error=maybe-uninitialized"
  28. do_install_append_class-target() {
  29. # cleanup buildpaths from gdlib.pc
  30. sed -i -e 's#${STAGING_DIR_HOST}##g' ${D}${libdir}/pkgconfig/gdlib.pc
  31. }
  32. PACKAGES += "${PN}-tools"
  33. FILES_${PN} = "${libdir}/lib*${SOLIBS}"
  34. FILES_${PN}-tools = "${bindir}/*"
  35. PROVIDES += "${PN}-tools"
  36. RPROVIDES_${PN}-tools = "${PN}-tools"
  37. RDEPENDS_${PN}-tools = "perl perl-module-strict"
  38. CVE_PRODUCT = "libgd"
  39. BBCLASSEXTEND = "native nativesdk"