python3-ldap_3.3.1.bb 1022 B

12345678910111213141516171819202122232425262728293031
  1. #
  2. # Copyright (C) 2012 Wind River Systems, Inc.
  3. #
  4. SUMMARY = "Provides a wrapper in Python to LDAP"
  5. DESCRIPTION = "This module provides access to the LDAP \
  6. (Lightweight Directory Access Protocol) through Python operations \
  7. instead of C API. The module mainly acts as a wrapper for the \
  8. OpenLDAP 2.x libraries. Errors will appear as exceptions."
  9. LICENSE = "PSF"
  10. HOMEPAGE = "http://www.python-ldap.org/"
  11. DEPENDS = "python3 openldap cyrus-sasl"
  12. PYPI_PACKAGE = "python-ldap"
  13. inherit pypi setuptools3
  14. LIC_FILES_CHKSUM = "file://LICENCE;md5=36ce9d726d0321b73c1521704d07db1b"
  15. SRC_URI[md5sum] = "7608579722c491e42f5f63b3f88a95fb"
  16. SRC_URI[sha256sum] = "4711cacf013e298754abd70058ccc995758177fb425f1c2d30e71adfc1d00aa5"
  17. do_configure_prepend() {
  18. sed -i -e 's:^library_dirs =.*::' ${S}/setup.cfg
  19. sed -i -e 's:^include_dirs =.*:include_dirs = =/usr/include/sasl/:' ${S}/setup.cfg
  20. }
  21. RDEPENDS_${PN} = " \
  22. ${PYTHON_PN}-pprint \
  23. ${PYTHON_PN}-threading \
  24. ${PYTHON_PN}-pyasn1 \
  25. ${PYTHON_PN}-pyasn1-modules \
  26. "