libkcapi_1.2.1.bb 1.1 KB

123456789101112131415161718192021222324252627282930
  1. SUMMARY = "Linux Kernel Crypto API User Space Interface Library"
  2. HOMEPAGE = "http://www.chronox.de/libkcapi.html"
  3. LICENSE = "BSD | GPL-2.0"
  4. LIC_FILES_CHKSUM = "file://COPYING;md5=c78be93ed8d1637f2a3f4a83ff9d5f54"
  5. DEPENDS = "libtool"
  6. S = "${WORKDIR}/git"
  7. SRCREV = "d41284525ec8960e9a828979cfe269012b7df8db"
  8. SRC_URI = "git://github.com/smuellerDD/libkcapi.git \
  9. file://0001-Disable-use-of-__NR_io_getevents-when-not-defined.patch \
  10. "
  11. inherit autotools
  12. PACKAGECONFIG ??= ""
  13. PACKAGECONFIG[testapp] = "--enable-kcapi-test,,,bash"
  14. PACKAGECONFIG[apps] = "--enable-kcapi-speed --enable-kcapi-hasher --enable-kcapi-rngapp --enable-kcapi-encapp --enable-kcapi-dgstapp,,,"
  15. do_install_append() {
  16. # bindir contains testapp and apps. However it is always created, even
  17. # when no binaries are installed (empty bin_PROGRAMS in Makefile.am),
  18. rmdir --ignore-fail-on-non-empty ${D}${bindir}
  19. # Remove the generated binary checksum files
  20. rm -f ${D}${bindir}/.*.hmac
  21. rm -f ${D}${libdir}/.*.hmac
  22. }
  23. CPPFLAGS_append_libc-musl_toolchain-clang = " -Wno-error=sign-compare"