gimp_2.10.22.bb 1.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263
  1. SUMMARY = "The GIMP is the GNU Image Manipulation Program"
  2. HOMEPAGE = "http://www.gimp.org"
  3. SECTION = "x11/graphics"
  4. LICENSE = "GPLv3"
  5. LIC_FILES_CHKSUM = "file://COPYING;md5=c678957b0c8e964aa6c70fd77641a71e"
  6. DEPENDS = " \
  7. gdk-pixbuf-native \
  8. intltool-native \
  9. libxslt-native \
  10. gegl-native \
  11. dbus-glib \
  12. gtk+ \
  13. babl \
  14. gegl \
  15. libmypaint \
  16. mypaint-brushes-1.0 \
  17. gexiv2 \
  18. jpeg \
  19. libpng \
  20. libexif \
  21. tiff \
  22. lcms \
  23. poppler \
  24. poppler-data \
  25. jasper \
  26. bzip2 \
  27. libgudev \
  28. libmng \
  29. ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxmu libxpm', '', d)} \
  30. "
  31. DEPENDS_append_libc-musl = " libexecinfo"
  32. inherit features_check gnomebase gtk-icon-cache gtk-doc mime-xdg
  33. REQUIRED_DISTRO_FEATURES = "x11"
  34. SHPV = "${@gnome_verdir("${PV}")}"
  35. SRC_URI = "https://download.gimp.org/pub/${BPN}/v${SHPV}/${BP}.tar.bz2"
  36. SRC_URI[sha256sum] = "2db84b57f3778d80b3466d7c21a21d22e315c7b062de2883cbaaeda9a0f618bb"
  37. EXTRA_OECONF = "--disable-python \
  38. --without-webkit \
  39. --without-wmf"
  40. EXTRA_OECONF_append_libc-musl_mipsarch = " --disable-vector-icons"
  41. EXTRA_OECONF_append_toolchain-clang_arm = " --disable-vector-icons"
  42. do_configure_append() {
  43. find ${B} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
  44. find ${B} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
  45. }
  46. do_compile_prepend() {
  47. # Let native babl/gegl find their plugins
  48. export BABL_PATH=`find ${STAGING_LIBDIR_NATIVE} -maxdepth 1 -name 'babl-*'`
  49. export GEGL_PATH=`find ${STAGING_LIBDIR_NATIVE} -maxdepth 1 -name 'gegl-*'`
  50. }
  51. FILES_${PN} += "${datadir}/metainfo"
  52. RDEPENDS_${PN} += "mypaint-brushes-1.0"