keyutils_1.6.1.bb 1.9 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465
  1. SUMMARY = "Linux Key Management Utilities"
  2. DESCRIPTION = "\
  3. Utilities to control the kernel key management facility and to provide \
  4. a mechanism by which the kernel call back to userspace to get a key \
  5. instantiated. \
  6. "
  7. HOMEPAGE = "http://people.redhat.com/dhowells/keyutils"
  8. SECTION = "base"
  9. LICENSE = "LGPLv2.1+ & GPLv2.0+"
  10. LIC_FILES_CHKSUM = "file://LICENCE.GPL;md5=5f6e72824f5da505c1f4a7197f004b45 \
  11. file://LICENCE.LGPL;md5=7d1cacaa3ea752b72ea5e525df54a21f"
  12. inherit siteinfo autotools-brokensep ptest
  13. SRC_URI = "http://people.redhat.com/dhowells/keyutils/${BP}.tar.bz2 \
  14. file://keyutils-test-fix-output-format.patch \
  15. file://keyutils-fix-error-report-by-adding-default-message.patch \
  16. file://run-ptest \
  17. file://fix_library_install_path.patch \
  18. "
  19. SRC_URI[md5sum] = "919af7f33576816b423d537f8a8692e8"
  20. SRC_URI[sha256sum] = "c8b15722ae51d95b9ad76cc6d49a4c2cc19b0c60f72f61fb9bf43eea7cbd64ce"
  21. EXTRA_OEMAKE = "'CFLAGS=${CFLAGS} -Wall' \
  22. NO_ARLIB=1 \
  23. BINDIR=${base_bindir} \
  24. SBINDIR=${base_sbindir} \
  25. LIBDIR=${libdir} \
  26. USRLIBDIR=${libdir} \
  27. INCLUDEDIR=${includedir} \
  28. BUILDFOR=${SITEINFO_BITS}-bit \
  29. NO_GLIBC_KEYERR=1 \
  30. "
  31. do_install () {
  32. install -d ${D}/${libdir}/pkgconfig
  33. oe_runmake DESTDIR=${D} install
  34. }
  35. do_install_append_class-nativesdk() {
  36. install -d ${D}${datadir}
  37. src_dir="${D}${target_datadir}"
  38. mv $src_dir/* ${D}${datadir}
  39. par_dir=`dirname $src_dir`
  40. rmdir $src_dir $par_dir
  41. install -d ${D}${sysconfdir}
  42. mv ${D}/etc/* ${D}${sysconfdir}/
  43. rmdir ${D}/etc
  44. }
  45. do_install_ptest () {
  46. cp -r ${S}/tests ${D}${PTEST_PATH}/
  47. sed -i -e 's/OSDIST=Unknown/OSDIST=${DISTRO}/' ${D}${PTEST_PATH}/tests/prepare.inc.sh
  48. }
  49. RDEPENDS_${PN}-ptest += "lsb-release"
  50. RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-utils"
  51. RDEPENDS_${PN}-ptest_append_libc-musl = " musl-utils"
  52. BBCLASSEXTEND = "native nativesdk"