libextutils-cppguess-perl_0.21.bb 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637
  1. SUMMARY = "ExtUtils::CppGuess - guess C++ compiler and flags"
  2. DESCRIPTION = "ExtUtils::CppGuess attempts to guess the system's C++ \
  3. compiler that is compatible with the C compiler that your perl was built \
  4. with. \
  5. It can generate the necessary options to the Module::Build constructor or \
  6. to ExtUtils::MakeMaker's WriteMakefile function."
  7. SECTION = "libs"
  8. HOMEPAGE = "http://search.cpan.org/~smueller/ExtUtils-CppGuess/"
  9. LICENSE = "Artistic-1.0 | GPL-1.0+"
  10. LIC_FILES_CHKSUM = "file://README;beginline=81;endline=84;md5=84c0390b90ea8c6702ce659b67bed699"
  11. SRC_URI = "${CPAN_MIRROR}/authors/id/E/ET/ETJ/ExtUtils-CppGuess-${PV}.tar.gz"
  12. SRC_URI[md5sum] = "62bdf731bcbe988d07486836e11585f7"
  13. SRC_URI[sha256sum] = "ff629178321a1e591b83f809712593eae4408a413aa448654bce59b156f24153"
  14. S = "${WORKDIR}/ExtUtils-CppGuess-${PV}"
  15. inherit cpan
  16. do_install () {
  17. cpan_do_install
  18. }
  19. RDEPENDS_${PN} = " libcapture-tiny-perl \
  20. perl-module-scalar-util \
  21. perl-module-io-file \
  22. perl-module-extutils-makemaker \
  23. perl-module-file-spec \
  24. perl-module-exporter \
  25. perl-module-carp \
  26. perl-module-file-temp \
  27. perl-module-lib \
  28. "
  29. BBCLASSEXTEND = "native"