passwdqc_1.3.1.bb 2.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566
  1. SUMMARY = "A password/passphrase strength checking and enforcement toolset"
  2. DESCRIPTION = "\
  3. passwdqc is a password/passphrase strength checking and policy enforcement \
  4. toolset, including an optional PAM module (pam_passwdqc), command-line \
  5. programs (pwqcheck and pwqgen), and a library (libpasswdqc). \
  6. pam_passwdqc is normally invoked on password changes by programs such as \
  7. passwd(1). It is capable of checking password or passphrase strength, \
  8. enforcing a policy, and offering randomly-generated passphrases, with \
  9. all of these features being optional and easily (re-)configurable. \
  10. \
  11. pwqcheck and pwqgen are standalone password/passphrase strength checking \
  12. and random passphrase generator programs, respectively, which are usable \
  13. from scripts. \
  14. \
  15. libpasswdqc is the underlying library, which may also be used from \
  16. third-party programs. \
  17. "
  18. HOMEPAGE = "http://www.openwall.com/passwdqc"
  19. SECTION = "System Environment/Base"
  20. DEPENDS += "libpam"
  21. inherit features_check
  22. REQUIRED_DISTRO_FEATURES = "pam"
  23. LICENSE = "BSD-1-Clause"
  24. LIC_FILES_CHKSUM = "file://LICENSE;md5=1b4af6f3d4ee079a38107366e93b334d"
  25. SRC_URI = "http://www.openwall.com/${BPN}/${BP}.tar.gz \
  26. file://makefile-add-ldflags.patch \
  27. "
  28. SRC_URI[md5sum] = "3878b57bcd3fdbcf3d4b362dbc6228b9"
  29. SRC_URI[sha256sum] = "d1fedeaf759e8a0f32d28b5811ef11b5a5365154849190f4b7fab670a70ffb14"
  30. # explicitly define LINUX_PAM in case DISTRO_FEATURES no pam
  31. # this package's pam_passwdqc.so needs pam
  32. CFLAGS_append = " -Wall -fPIC -DHAVE_SHADOW -DLINUX_PAM"
  33. # -e is no longer default setting in bitbake.conf
  34. EXTRA_OEMAKE = "-e"
  35. do_compile() {
  36. # make sure sub make use environment to override variables in Makefile
  37. # Linux) $(MAKE), there is a tab between
  38. sed -i -e 's/Linux) $(MAKE) CFLAGS_lib/Linux) $(MAKE) -e CFLAGS_lib/' ${S}/Makefile
  39. # LD_lib and LD must be CC because of Makefile
  40. oe_runmake LD="${CC}"
  41. }
  42. do_install() {
  43. oe_runmake install DESTDIR=${D} SHARED_LIBDIR=${base_libdir} \
  44. DEVEL_LIBDIR=${libdir} SECUREDIR=${base_libdir}/security \
  45. INSTALL="install -p"
  46. }
  47. PROVIDES += "pam-${BPN}"
  48. PACKAGES =+ "lib${BPN} pam-${BPN}"
  49. FILES_lib${BPN} = "${base_libdir}/libpasswdqc.so.0"
  50. FILES_pam-${BPN} = "${base_libdir}/security/pam_passwdqc.so"
  51. FILES_${PN}-dbg += "${base_libdir}/security/.debug"
  52. RDEPENDS_${PN} = "lib${BPN} pam-${BPN}"
  53. RDEPENDS_pam-${BPN} = "lib${BPN}"