entrance_svn.bb 1.6 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. SUMMARY = "Login manager for Enlightenment"
  2. DEPENDS = "efreet eina eet ecore elementary"
  3. LICENSE = "GPLv3+"
  4. LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
  5. SECTION = "e/apps"
  6. inherit e gettext systemd
  7. SRC_URI = "${E_SVN}/trunk/PROTO;module=${SRCNAME};protocol=http;scmdata=keep \
  8. file://0001-pam-use-common-auth-instead-of-system-auth.patch \
  9. file://entrance.service \
  10. "
  11. S = "${WORKDIR}/${SRCNAME}"
  12. PNBLACKLIST[entrance] ?= "broken: switch to https://git.enlightenment.org/misc/entrance.git and fix 0.0.4+svnr82070-r7/entrance/data/themes/old/default.edc:678. invalid state name: 'defaault'. "default" state must always be first. - the recipe will be removed on 2017-09-01 unless the issue is fixed"
  13. PACKAGECONFIG ??= ""
  14. PACKAGECONFIG[consolekit] = "--enable-consolekit,--disable-consolekit,consolekit"
  15. EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '', '--disable-pam', d)}"
  16. PR = "r7"
  17. PV = "0.0.4+svnr${SRCPV}"
  18. SRCREV = "${EFL_SRCREV}"
  19. RDEPENDS_${PN} += "${PN}-themes sessreg xauth"
  20. CONFFILES_${PN} += "${sysconfdir}/entrance.conf"
  21. RCONFLICTS_${PN} += "xserver-nodm-init"
  22. RREPLACES_${PN} += "xserver-nodm-init"
  23. RCONFLICTS_${PN} += "xserver-nodm-init-systemd"
  24. RREPLACES_${PN} += "xserver-nodm-init-systemd"
  25. RPROVIDES_${PN} += "${PN}-systemd"
  26. RREPLACES_${PN} += "${PN}-systemd"
  27. RCONFLICTS_${PN} += "${PN}-systemd"
  28. SYSTEMD_SERVICE_${PN} = "entrance.service"
  29. do_install_append() {
  30. install -d ${D}${systemd_unitdir}/system
  31. install -m 0644 ${WORKDIR}/entrance.service ${D}${systemd_unitdir}/system
  32. }