exquisite_svn.bb 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. SUMMARY = "A psplash replacement for display"
  2. LICENSE = "MIT & BSD"
  3. LIC_FILES_CHKSUM = "file://COPYING;md5=14defa372a91118e755133bc8e6aff83"
  4. DEPENDS = "eet evas ecore embryo edje"
  5. PV = "0.0.1+svnr${SRCPV}"
  6. SRCREV = "${EFL_SRCREV}"
  7. RRECOMMENDS_${PN} = "exquisite-themes"
  8. RCONFLICTS_${PN} = "psplash virtual-psplash"
  9. SRCNAME = "exquisite"
  10. inherit e
  11. SRC_URI = "${E_SVN}/trunk;module=${SRCNAME};protocol=http;scmdata=keep"
  12. S = "${WORKDIR}/${SRCNAME}"
  13. EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
  14. SRC_URI += "file://exquisite-init"
  15. SRC_URI += "file://splashfuncs"
  16. inherit update-rc.d
  17. do_install_prepend() {
  18. install -d ${D}/mnt/.splash/
  19. install -d ${D}${sysconfdir}/init.d
  20. install -m 0755 ${WORKDIR}/exquisite-init ${D}${sysconfdir}/init.d/exquisite
  21. install -d ${D}${sysconfdir}/default
  22. install -m 0755 ${WORKDIR}/splashfuncs ${D}${sysconfdir}/default/splashfuncs
  23. install -d ${D}${bindir}
  24. ln -s exquisite-write ${D}${bindir}/splash-write
  25. }
  26. do_install_append() {
  27. rm -rf ${D}${datadir}/exquisite/data/fonts/*
  28. }
  29. INITSCRIPT_NAME = "exquisite"
  30. INITSCRIPT_PARAMS = "start 01 S . stop 20 0 1 6 ."
  31. FILES_${PN} += "/mnt/.splash/"
  32. PNBLACKLIST[exquisite] ?= "Fails to build with RSS http://errors.yoctoproject.org/Errors/Details/130619/ - the recipe will be removed on 2017-09-01 unless the issue is fixed"