enjoy_git.bb 1.7 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. SUMMARY = "Enjoy music player"
  2. LICENSE = "LGPLv3"
  3. LIC_FILES_CHKSUM = "file://COPYING;md5=6a6a8e020838b23406c81b19c1d46df6"
  4. DEPENDS = "evas ecore edje elementary emotion lightmediascanner eldbus gst-plugins-good"
  5. SRCREV = "aa8fec69e885eec048a849c2b34059ec58404e02"
  6. PV = "0.1.0+gitr${SRCPV}"
  7. #1st needed for all formats
  8. #2nd needed for mp3 playback
  9. #3d needed for ogg playback
  10. #4th needed for flac playback
  11. #5th needed binary to create db
  12. RDEPENDS_${PN} += "\
  13. gst-plugins-base-typefindfunctions gst-plugins-base-playbin gst-plugins-base-volume gst-plugins-base-decodebin2 gst-plugins-good-autodetect \
  14. gst-plugins-base-ogg gst-plugins-base-ivorbisdec \
  15. gst-plugins-good-flac \
  16. lightmediascanner-test \
  17. "
  18. inherit e gettext
  19. SRC_URI = " \
  20. git://git.enlightenment.org/apps/enjoy.git \
  21. file://0001-always-use-position-as-percent-and-define-a-1-second.patch \
  22. file://configure.patch \
  23. "
  24. S = "${WORKDIR}/git"
  25. FILES_${PN} += "${datadir}/icons/"
  26. EXTRA_OECONF = "\
  27. --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
  28. "
  29. PACKAGECONFIG[mad] = ",,gst-plugins-ugly,gst-plugins-ugly-mad"
  30. PACKAGECONFIG[id3demux] = ",,,gst-plugins-good-id3demux"
  31. do_configure_prepend() {
  32. autopoint || touch config.rpath
  33. }
  34. pkg_postinst_${PN} () {
  35. echo "enjoy: SCAN and LIBRARY MANAGER are not implemeted yet!"
  36. echo "enjoy: Meanwhile please run:"
  37. echo "enjoy: test-lms -m mono -p id3 -i 5000 -s /path/to/your/music/dir /home/root/.config/enjoy/media.db"
  38. echo "enjoy:"
  39. echo "enjoy: Use test-lms -P to see available formats that can be scanned"
  40. }
  41. PNBLACKLIST[enjoy] ?= "Depends on blacklisted elementary - the recipe will be removed on 2017-09-01 unless the issue is fixed"