e-wm-theme-b-and-w_svn.bb 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637
  1. DESCRIPTION = "b-and-w theme was default E17 theme before alpha3 and some people still prefers it."
  2. SECTION = "e/utils"
  3. DEPENDS = "edje-native"
  4. RDEPENDS_${PN} = "e-wm"
  5. LICENSE = "MIT & BSD"
  6. # upstream was asked to include license infor in THEME dir
  7. LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
  8. inherit allarch
  9. SRCREV = "${EFL_SRCREV}"
  10. PV = "0.0+svnr${SRCPV}"
  11. inherit e-base
  12. SRCNAME = "b_and_w"
  13. SRC_URI = "${E_SVN}/trunk/THEMES;module=${SRCNAME};protocol=http"
  14. S = "${WORKDIR}/${SRCNAME}/e"
  15. do_compile() {
  16. # unfortunately hardcoded edje_cc in Makefile
  17. sed -i "s#\tedje_cc#\t${STAGING_BINDIR_NATIVE}/edje_cc#g" Makefile
  18. make
  19. }
  20. do_install() {
  21. install -d ${D}${datadir}/enlightenment/data/themes/
  22. install -m 0644 ${S}/b_and_w.edj ${D}${datadir}/enlightenment/data/themes/
  23. }
  24. FILES_${PN} = "${datadir}/enlightenment/data/themes/"
  25. PNBLACKLIST[e-wm-theme-b-and-w] ?= "Runtime depends on blacklisted e-wm - the recipe will be removed on 2017-09-01 unless the issue is fixed"
  26. PNBLACKLIST[e-wm-theme-b-and-w] ?= "Runtime depends on blacklisted e-wm-theme-b-and-w - the recipe will be removed on 2017-09-01 unless the issue is fixed"
  27. PNBLACKLIST[e-wm-theme-b-and-w] ?= "Runtime depends on blacklisted e-wm-theme-b-and-w-dev - the recipe will be removed on 2017-09-01 unless the issue is fixed"