intel-speed-select.bb 773 B

123456789101112131415161718192021222324252627282930
  1. SUMMARY = "A tool to validate Intel Speed Select commands"
  2. DESCRIPTION = "The Intel Speed Select Technology (Intel SST) is a powerful new \
  3. collection of features giving you more granular control over CPU performance \
  4. for optimized total cost of ownership."
  5. LICENSE = "GPLv2"
  6. inherit kernelsrc
  7. COMPATIBLE_HOST = '(x86_64|i.86).*-linux'
  8. COMPATIBLE_HOST_libc-musl = 'null'
  9. do_populate_lic[depends] += "virtual/kernel:do_patch"
  10. B = "${WORKDIR}/${BPN}-${PV}"
  11. EXTRA_OEMAKE = "-C ${S}/tools/power/x86/intel-speed-select O=${B} CROSS=${TARGET_PREFIX} CC="${CC}" LD="${LD}" AR=${AR} ARCH=${ARCH}"
  12. PACKAGE_ARCH = "${MACHINE_ARCH}"
  13. do_configure[depends] += "virtual/kernel:do_shared_workdir"
  14. do_compile() {
  15. oe_runmake
  16. }
  17. do_install() {
  18. oe_runmake DESTDIR=${D} install
  19. }