libcdio_2.1.0.bb 1.1 KB

1234567891011121314151617181920212223242526272829
  1. SUMMARY = "The GNU Compact Disc Input and Control library (libcdio) contains a library for CD-ROM and CD image access."
  2. HOMEPAGE = "http://www.gnu.org/software/libcdio/"
  3. SECTION = "libs"
  4. LICENSE = "GPLv3+"
  5. LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
  6. SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.bz2"
  7. SRC_URI[md5sum] = "aa7629e8f73662a762f64c444b901055"
  8. SRC_URI[sha256sum] = "8550e9589dbd594bfac93b81ecf129b1dc9d0d51e90f9696f1b2f9b2af32712b"
  9. inherit autotools pkgconfig
  10. PACKAGECONFIG ??= "cdda-player"
  11. PACKAGECONFIG[cdda-player] = "--with-cdda-player,--without-cdda-player,ncurses"
  12. PACKAGECONFIG[cddb] = "--enable-cddb,--disable-cddb,libcddb"
  13. PACKAGECONFIG[vcd-info] = "--enable-vcd-info,--disable-vcd-info,vcdimager"
  14. PACKAGES += "${PN}-utils"
  15. FILES_${PN} = "${libdir}/${BPN}${SOLIB}"
  16. FILES_${PN}-utils = "${bindir}/*"
  17. python libcdio_split_packages() {
  18. libdir = d.expand('${libdir}')
  19. do_split_packages(d, libdir, '^lib(.*)\.so\..*', 'lib%s', 'libcdio %s library', extra_depends='', allow_links=True)
  20. }
  21. PACKAGESPLITFUNCS =+ "libcdio_split_packages"