pmtools_git.bb 936 B

12345678910111213141516171819202122232425262728293031323334
  1. DESCRIPTION = "This is a small collection of power management \
  2. test and investigation tools"
  3. HOMEPAGE = "http://lesswatts.org/projects/acpi"
  4. LICENSE = "GPLv2+"
  5. LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
  6. PV = "20130209+git${SRCPV}"
  7. SRC_URI = "git://github.com/anyc/pmtools.git \
  8. file://pmtools-switch-to-dynamic-buffer-for-huge-ACPI-table.patch \
  9. "
  10. SRCREV = "3ebe0e54c54061b4c627236cbe35d820de2e1168"
  11. COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
  12. S = "${WORKDIR}/git"
  13. inherit update-alternatives
  14. ALTERNATIVE_PRIORITY = "90"
  15. ALTERNATIVE_${PN} = "acpixtract acpidump"
  16. do_configure[noexec] = "1"
  17. do_compile() {
  18. oe_runmake
  19. }
  20. do_install() {
  21. install -d ${D}${bindir} ${D}${docdir}
  22. install -m 755 ${S}/acpidump/acpidump ${D}${bindir}
  23. install -m 755 ${S}/acpixtract/acpixtract ${D}${bindir}
  24. install -m 755 ${S}/madt/madt ${D}${bindir}
  25. install -m 644 ${S}/README ${D}${docdir}
  26. }