rsnapshot_git.bb 1.7 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. SUMMARY = "A filesystem snapshot utility based on rsync"
  2. HOMEPAGE = "http://www.rsnapshot.org"
  3. BUGTRACKER = "https://sourceforge.net/projects/rsnapshot/"
  4. SECTION = "console/network"
  5. LICENSE = "GPLv2"
  6. LIC_FILES_CHKSUM = "file://COPYING;md5=892f569a555ba9c07a568a7c0c4fa63a"
  7. RDEPENDS_${PN} = "rsync \
  8. perl \
  9. perl-module-dirhandle \
  10. perl-module-cwd \
  11. perl-module-getopt-std \
  12. perl-module-file-path \
  13. perl-module-file-stat \
  14. perl-module-posix \
  15. perl-module-fcntl \
  16. perl-module-io-file \
  17. perl-module-constant \
  18. perl-module-overloading \
  19. "
  20. SRCREV = "27209563f924a22f510698ea225f53ea52f07cb4"
  21. PV = "1.4.2+git${SRCPV}"
  22. SRC_URI = "git://github.com/DrHyde/${BPN};branch=master;protocol=git \
  23. file://configure-fix-cmd_rsync.patch \
  24. "
  25. S = "${WORKDIR}/git"
  26. inherit autotools perlnative
  27. # Fix rsnapshot.conf.default:
  28. # don't inject the host path into target configs.
  29. EXTRA_OECONF += "--without-cp \
  30. --without-rm \
  31. --without-du \
  32. --without-ssh \
  33. --without-logger \
  34. --without-rsync \
  35. ac_cv_path_PERL=${bindir}/perl \
  36. ac_cv_path_MOUNT=${base_bindir}/mount \
  37. ac_cv_path_UMOUNT=${base_bindir}/umount \
  38. "
  39. # Create 't/include.ac' before starting the autoreconf to fix configure
  40. # error: configure.ac:302: file 't/include.ac' does not exist
  41. do_configure_prepend(){
  42. saved_dir=`pwd`
  43. cd ${S}; ./autogen.sh
  44. cd ${saved_dir}
  45. }