dbus-cxx_0.12.bb 576 B

1234567891011121314151617181920212223242526
  1. SUMMARY = "D-Bus wrapper in C++ for dbus"
  2. HOMEPAGE = "https://dbus-cxx.github.io/"
  3. SECTION = "base"
  4. LICENSE = "GPLv3"
  5. LIC_FILES_CHKSUM = "file://COPYING;md5=4cf0188f02184e1e84b9586ac53c3f83"
  6. FILEEXTRAPATHS_prepend = "${THISDIR}/files"
  7. SRC_URI = "git://github.com/dbus-cxx/dbus-cxx.git;branch=master"
  8. SRC_URI += "file://fix_build_musl.patch"
  9. SRCREV = "ea7f8e361d11dc7d41d9ae2c4128aed2cdadd84e"
  10. DEPENDS = "\
  11. dbus \
  12. libsigc++-2.0 \
  13. "
  14. RDEPENDS_${PN} = "\
  15. dbus \
  16. libsigc++-2.0 \
  17. "
  18. S = "${WORKDIR}/git"
  19. inherit pkgconfig cmake
  20. OECMAKE_FIND_ROOT_PATH_MODE_PROGRAM = "BOTH"