nmap_7.80.bb 2.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960
  1. SUMMARY = "network auditing tool"
  2. DESCRIPTION = "Nmap ("Network Mapper") is a free and open source (license) utility for network discovery and security auditing.\nGui support via appending to IMAGE_FEATURES x11-base in local.conf"
  3. SECTION = "security"
  4. LICENSE = "GPL-2.0"
  5. LIC_FILES_CHKSUM = "file://COPYING;beginline=7;endline=12;md5=66938a7e5b4c118eda78271de14874c2"
  6. SRC_URI = "http://nmap.org/dist/${BP}.tar.bz2 \
  7. file://nmap-redefine-the-python-library-dir.patch \
  8. file://nmap-replace-shtool-mkdir-with-coreutils-mkdir-command.patch \
  9. file://0001-Include-time.h-header-to-pass-clang-compilation.patch \
  10. file://0002-Fix-building-with-libc.patch \
  11. file://0001-Make-ndiff-support-python3.patch \
  12. file://0001-configure.ac-make-ndiff-depend-on-python3.patch \
  13. "
  14. SRC_URI[md5sum] = "d37b75b06d1d40f27b76d60db420a1f5"
  15. SRC_URI[sha256sum] = "fcfa5a0e42099e12e4bf7a68ebe6fde05553383a682e816a7ec9256ab4773faa"
  16. inherit autotools-brokensep pkgconfig python3native
  17. PACKAGECONFIG ?= "ncat nping ndiff pcap"
  18. PACKAGECONFIG[pcap] = "--with-pcap=linux, --without-pcap, libpcap, libpcap"
  19. PACKAGECONFIG[pcre] = "--with-libpcre=${STAGING_LIBDIR}/.., --with-libpcre=included, libpcre"
  20. PACKAGECONFIG[ssl] = "--with-openssl=${STAGING_LIBDIR}/.., --without-openssl, openssl, openssl"
  21. PACKAGECONFIG[ssh2] = "--with-openssh2=${STAGING_LIBDIR}/.., --without-openssh2, libssh2, libssh2"
  22. PACKAGECONFIG[libz] = "--with-libz=${STAGING_LIBDIR}/.., --without-libz, zlib, zlib"
  23. #disable/enable packages
  24. PACKAGECONFIG[nping] = ",--without-nping,"
  25. PACKAGECONFIG[ncat] = ",--without-ncat,"
  26. PACKAGECONFIG[ndiff] = "--with-ndiff=yes,--without-ndiff,python3"
  27. PACKAGECONFIG[update] = ",--without-nmap-update,"
  28. EXTRA_OECONF = "--with-libdnet=included --with-liblinear=included --without-subversion --with-liblua=included"
  29. # zenmap needs python-pygtk which has been removed
  30. # it also only works with python2
  31. # disable for now until py3 is supported
  32. EXTRA_OECONF += "--without-zenmap"
  33. export PYTHON_SITEPACKAGES_DIR
  34. do_configure() {
  35. autoconf
  36. install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}
  37. install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}
  38. oe_runconf
  39. }
  40. do_install_append() {
  41. if [ -f "${D}${bindir}/ndiff" ]; then
  42. sed -i 's@^#!.*$@#!/usr/bin/env python3@g' ${D}${bindir}/ndiff
  43. fi
  44. }
  45. FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR} ${datadir}/ncat"
  46. RDEPENDS_${PN} += "python3-core"