gpm_git.bb 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839
  1. SUMMARY = "Console mouse driver"
  2. DESCRIPTION = "GPM (General Purpose Mouse) is a mouse server \
  3. for the console and xterm, with sample clients included \
  4. (emacs, etc)."
  5. HOMEPAGE = "https://www.nico.schottelius.org/software/gpm"
  6. SECTION = "console/utils"
  7. LICENSE = "GPLv2+"
  8. LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760"
  9. PV = "1.99.7+git${SRCREV}"
  10. PR = "r2"
  11. SRCREV = "e82d1a653ca94aa4ed12441424da6ce780b1e530"
  12. DEPENDS = "ncurses bison-native"
  13. SRC_URI = "git://github.com/telmich/gpm;protocol=git \
  14. file://init \
  15. file://gpm.service.in \
  16. "
  17. S = "${WORKDIR}/git"
  18. inherit autotools-brokensep update-rc.d systemd texinfo
  19. INITSCRIPT_NAME = "gpm"
  20. INITSCRIPT_PARAMS = "defaults"
  21. do_configure_prepend() {
  22. (cd ${S};./autogen.sh;cd -)
  23. }
  24. do_install_append () {
  25. install -d ${D}${systemd_system_unitdir}
  26. sed 's:@bindir@:${sbindir}:' < ${WORKDIR}/gpm.service.in >${D}${systemd_system_unitdir}/gpm.service
  27. install -D -m 0755 ${WORKDIR}/init ${D}${INIT_D_DIR}/gpm
  28. ln -s libgpm.so.2 ${D}${libdir}/libgpm.so
  29. }
  30. SYSTEMD_SERVICE_${PN} = "gpm.service"