iptraf_3.0.0.bb 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. DESCRIPTION = "IPTraf is a console-based network statistics utility for Linux. \
  2. It gathers a variety of figures such as TCP connection packet and byte counts, \
  3. interface statistics and activity indicators, TCP/UDP traffic breakdowns, \
  4. and LAN station packet and byte counts."
  5. HOMEPAGE = "http://iptraf.seul.org"
  6. LICENSE = "GPLv2"
  7. LIC_FILES_CHKSUM = "file://LICENSE;md5=dc0bdc29df738baf327368b1bbb15a45"
  8. DEPENDS = "ncurses"
  9. SRC_URI = " \
  10. ftp://iptraf.seul.org/pub/iptraf/iptraf-3.0.0.tar.gz \
  11. file://0001-src-Fix-error-in-cross-compile.patch \
  12. file://format_string.patch \
  13. file://ldopts.patch \
  14. "
  15. SRC_URI[md5sum] = "377371c28ee3c21a76f7024920649ea8"
  16. SRC_URI[sha256sum] = "9ee433d95573d612539da4b452e6cdcbca6ab6674a88bfbf6eaf12d4902b5163"
  17. RDEPENDS_${PN} = "ncurses"
  18. EXTRA_OEMAKE = "-e MAKEFLAGS= LDOPTS='${LDFLAGS}' ARCH='${TARGET_ARCH}'"
  19. do_compile() {
  20. oe_runmake -C src all
  21. }
  22. do_install_append() {
  23. rm -r ${D}/${localstatedir}/run
  24. }
  25. do_install() {
  26. install -d ${D}${bindir}
  27. oe_runmake -C src install \
  28. TARGET=${D}${bindir} \
  29. WORKDIR=${D}${localstatedir}/local/iptraf \
  30. LOGDIR=${D}${localstatedir}/log/iptraf \
  31. LOCKDIR=${D}${localstatedir}/run/iptraf
  32. }
  33. FILES_${PN} += "${bindir} ${localstatedir} /run"