squashfs-tools-ng_1.0.2.bb 1.6 KB

1234567891011121314151617181920212223242526272829303132
  1. SUMMARY = "New set of tools for working with SquashFS images"
  2. SECTION = "base"
  3. LICENSE = "GPL-3.0+ & LGPL-3.0+ & MIT & BSD-2-Clause & Zlib"
  4. LIC_FILES_CHKSUM = "file://COPYING.md;md5=c0de2c0aca56349dab98e97992316f7e \
  5. file://licenses/GPLv3.txt;md5=1ebbd3e34237af26da5dc08a4e440464 \
  6. file://licenses/hash_table.txt;md5=874823605326caeaabaa95bfbd0f9fb0 \
  7. file://licenses/LGPLv3.txt;md5=3000208d539ec061b899bce1d9ce9404 \
  8. file://licenses/LZ4.txt;md5=ebc2ea4814a64de7708f1571904b32cc \
  9. file://licenses/xxhash.txt;md5=f042a9be092bd6d7fe6f217d8d00f4ca \
  10. file://licenses/xz.txt;md5=1c389b9610ccfdb25f7abaea6a0bb5a4 \
  11. file://licenses/zlib.txt;md5=ae27c72096606131f760e5f59cf98b06 \
  12. file://licenses/zstd.txt;md5=8df8137b630239cbdd4c0674124cb0c8"
  13. SRCREV = "b96f0fc154feef531be76034bf6e38925636146f"
  14. SRC_URI = "git://github.com/AgentD/squashfs-tools-ng.git;protocol=https"
  15. S = "${WORKDIR}/git"
  16. inherit autotools pkgconfig
  17. PACKAGECONFIG ??= "gzip xz lzo lz4 zstd ${@bb.utils.filter('DISTRO_FEATURES', 'selinux', d)}"
  18. PACKAGECONFIG[gzip] = "--with-gzip,--without-gzip,zlib"
  19. PACKAGECONFIG[xz] = "--with-xz,--without-xz,xz"
  20. PACKAGECONFIG[lzo] = "--with-lzo,--without-lzo,lzo"
  21. PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4"
  22. PACKAGECONFIG[zstd] = "--with-zstd,--without-zstd,zstd"
  23. PACKAGECONFIG[selinux] = "--with-selinux,--without-selinux,libselinux"
  24. PACKAGES =+ "libsquashfs"
  25. FILES_libsquashfs = "${libdir}/libsquashfs*${SOLIBS}"
  26. BBCLASSEXTEND = "native nativesdk"