tigervnc_1.9.0.bb 4.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131
  1. DESCRIPTION = "TigerVNC remote display system"
  2. HOMEPAGE = "http://www.tigervnc.com/"
  3. LICENSE = "GPLv2+"
  4. SECTION = "x11/utils"
  5. DEPENDS = "xserver-xorg gnutls jpeg libxtst gettext-native fltk"
  6. RDEPENDS_${PN} = "chkconfig coreutils hicolor-icon-theme"
  7. LIC_FILES_CHKSUM = "file://LICENCE.TXT;md5=75b02c2872421380bbd47781d2bd75d3"
  8. S = "${WORKDIR}/git"
  9. inherit features_check
  10. REQUIRED_DISTRO_FEATURES = "x11"
  11. inherit autotools cmake
  12. B = "${S}"
  13. SRCREV = "6f2301d08e64a965ad36b401ec8dc2b24bc47075"
  14. SRC_URI = "git://github.com/TigerVNC/tigervnc.git;branch=1.9-branch \
  15. file://0001-tigervnc-remove-includedir.patch \
  16. file://0002-do-not-build-tests-sub-directory.patch \
  17. file://0003-add-missing-dynamic-library-to-FLTK_LIBRARIES.patch \
  18. file://0004-tigervnc-add-fPIC-option-to-COMPILE_FLAGS.patch \
  19. "
  20. # Keep sync with xorg-server in oe-core
  21. XORG_PN ?= "xorg-server"
  22. XORG_PV ?= "1.19.6"
  23. SRC_URI += "${XORG_MIRROR}/individual/xserver/${XORG_PN}-${XORG_PV}.tar.bz2;name=xorg"
  24. XORG_S = "${WORKDIR}/${XORG_PN}-${XORG_PV}"
  25. SRC_URI[xorg.md5sum] = "3e47777ff034a331aed2322b078694a8"
  26. SRC_URI[xorg.sha256sum] = "a732502f1db000cf36a376cd0c010ffdbf32ecdd7f1fa08ba7f5bdf9601cc197"
  27. # It is the directory containing the Xorg source for the
  28. # machine on which you are building TigerVNC.
  29. XSERVER_SOURCE_DIR="${S}/unix/xserver"
  30. do_patch[postfuncs] += "do_patch_xserver"
  31. do_patch_xserver () {
  32. for subdir in Xext xkb GL hw/xquartz/bundle hw/xfree86/common; do
  33. install -d ${XSERVER_SOURCE_DIR}/$subdir
  34. done
  35. for subdir in hw/dmx/doc man doc hw/dmx/doxygen; do
  36. install -d ${XSERVER_SOURCE_DIR}/$subdir
  37. done
  38. sources="hw/xquartz/bundle/cpprules.in man/Xserver.man doc/smartsched \
  39. hw/dmx/doxygen/doxygen.conf.in xserver.ent.in xkb/README.compiled \
  40. hw/xfree86/xorgconf.cpp hw/xfree86/Xorg.sh.in"
  41. for i in ${sources}; do
  42. install -m 0644 ${XORG_S}/$i ${XSERVER_SOURCE_DIR}/$i;
  43. done
  44. cd ${XORG_S}
  45. find . -type f | egrep '.*\.(c|h|am|ac|inc|m4|h.in|pc.in|man.pre|pl|txt)$' | \
  46. xargs tar cf - | (cd ${XSERVER_SOURCE_DIR} && tar xf -)
  47. cd ${XSERVER_SOURCE_DIR}
  48. xserverpatch="${S}/unix/xserver119.patch"
  49. echo "Apply $xserverpatch"
  50. patch -p1 -b --suffix .vnc < $xserverpatch
  51. }
  52. EXTRA_OECONF = "--disable-xorg --disable-xnest --disable-xvfb --disable-dmx \
  53. --disable-xwin --disable-xephyr --disable-kdrive --with-pic \
  54. --disable-static --disable-xinerama \
  55. --with-xkb-output=${localstatedir}/lib/xkb \
  56. --disable-glx --disable-dri --disable-dri2 \
  57. --disable-config-hal \
  58. --disable-config-udev \
  59. --without-dtrace \
  60. --disable-unit-tests \
  61. --disable-devel-docs \
  62. --disable-selective-werror \
  63. --disable-xshmfence \
  64. --disable-config-udev \
  65. --disable-dri3 \
  66. --disable-libunwind \
  67. --without-xmlto \
  68. --enable-systemd-logind=no \
  69. --disable-xinerama \
  70. --disable-xwayland \
  71. "
  72. do_configure_append () {
  73. olddir=`pwd`
  74. cd ${XSERVER_SOURCE_DIR}
  75. rm -rf aclocal-copy/
  76. rm -f aclocal.m4
  77. export ACLOCALDIR="${XSERVER_SOURCE_DIR}/aclocal-copy"
  78. mkdir -p ${ACLOCALDIR}/
  79. if [ -d ${STAGING_DATADIR_NATIVE}/aclocal ]; then
  80. cp-noerror ${STAGING_DATADIR_NATIVE}/aclocal/ ${ACLOCALDIR}/
  81. fi
  82. if [ -d ${STAGING_DATADIR}/aclocal -a "${STAGING_DATADIR_NATIVE}/aclocal" != "${STAGING_DATADIR}/aclocal" ]; then
  83. cp-noerror ${STAGING_DATADIR}/aclocal/ ${ACLOCALDIR}/
  84. fi
  85. ACLOCAL="aclocal --system-acdir=${ACLOCALDIR}/" autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} $acpaths || bbfatal "autoreconf execution failed."
  86. chmod +x ./configure
  87. ${CACHED_CONFIGUREVARS} ./configure ${CONFIGUREOPTS} ${EXTRA_OECONF}
  88. cd $olddir
  89. }
  90. do_compile_append () {
  91. olddir=`pwd`
  92. cd ${XSERVER_SOURCE_DIR}
  93. oe_runmake
  94. cd $olddir
  95. }
  96. do_install_append() {
  97. olddir=`pwd`
  98. cd ${XSERVER_SOURCE_DIR}/hw/vnc
  99. oe_runmake 'DESTDIR=${D}' install
  100. cd $olddir
  101. }
  102. FILES_${PN} += " \
  103. ${libdir}/xorg/modules/extensions \
  104. ${datadir}/icons \
  105. "
  106. FILES_${PN}-dbg += "${libdir}/xorg/modules/extensions/.debug"