renderdoc_1.4.bb 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637
  1. SUMMARY = "RenderDoc recipe providing renderdoccmd"
  2. DESCRIPTION = "RenderDoc is a frame-capture based graphics debugger"
  3. HOMEPAGE = "https://github.com/baldurk/renderdoc"
  4. LICENSE = "MIT"
  5. LIC_FILES_CHKSUM = "file://LICENSE.md;md5=9753b1b4fba3261c27d1ce5c1acef667"
  6. SRCREV = "214d85228538e71cc63a0d7fa11dd75b1d56cc81"
  7. SRC_URI = "git://github.com/baldurk/${BPN}.git;protocol=http;branch=v1.x \
  8. file://0001-renderdoc-use-xxd-instead-of-cross-compiling-shim-bi.patch \
  9. "
  10. S = "${WORKDIR}/git"
  11. DEPENDS += "virtual/libx11 virtual/libgl libxcb xcb-util-keysyms vim-native"
  12. RDEPENDS_${PN} = "libxcb xcb-util-keysyms"
  13. inherit cmake python3native features_check
  14. REQUIRED_DISTRO_FEATURES = "x11 opengl"
  15. python __anonymous () {
  16. # only works on glibc systems
  17. if d.getVar('TCLIBC') != "glibc":
  18. raise bb.parse.SkipRecipe("incompatible with %s C library" % d.getVar('TCLIBC'))
  19. }
  20. COMPATIBLE_HOST = "(x86_64|i.86|arm|aarch64).*-linux"
  21. EXTRA_OECMAKE += "\
  22. -DENABLE_QRENDERDOC=OFF \
  23. -DENABLE_PYRENDERDOC=OFF \
  24. -DENABLE_RENDERDOCCMD=ON \
  25. -DCMAKE_BUILD_TYPE=Release \
  26. "
  27. FILES_${PN} += "${libdir}"
  28. FILES_${PN}-dev = "${includedir}"