openbox_3.6.1.bb 2.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. SUMMARY = "openbox Window Manager"
  2. SECTION = "x11/wm"
  3. DEPENDS = "glib-2.0 pango libxml2 virtual/libx11 libcroco librsvg gdk-pixbuf"
  4. LICENSE = "GPLv2+"
  5. LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
  6. SRC_URI = " \
  7. http://icculus.org/openbox/releases/openbox-${PV}.tar.gz \
  8. file://0001-Makefile.am-avoid-race-when-creating-autostart-direc.patch \
  9. "
  10. SRC_URI[md5sum] = "b72794996c6a3ad94634727b95f9d204"
  11. SRC_URI[sha256sum] = "8b4ac0760018c77c0044fab06a4f0c510ba87eae934d9983b10878483bde7ef7"
  12. inherit autotools gettext update-alternatives pkgconfig features_check
  13. # depends on virtual/libx11
  14. REQUIRED_DISTRO_FEATURES = "x11"
  15. ALTERNATIVE_${PN}-core = "x-window-manager x-session-manager"
  16. ALTERNATIVE_TARGET[x-window-manager] = "${bindir}/openbox"
  17. ALTERNATIVE_PRIORITY[x-window-manager] = "10"
  18. ALTERNATIVE_TARGET[x-session-manager] = "${bindir}/openbox-session"
  19. ALTERNATIVE_PRIORITY[x-session-manager] = "100"
  20. PACKAGECONFIG ??= ""
  21. PACKAGECONFIG[imlib2] = "--enable-imlib2,--disable-imlib2,imlib2"
  22. PACKAGECONFIG[startup-notification] = "--enable-startup-notification,--disable-startup-notification,startup-notification"
  23. PACKAGECONFIG[xrandr] = "--enable-xrandr,--disable-xrandr,libxrandr"
  24. PACKAGECONFIG[xinerama] = "--enable-xinerama,--disable-xinerama,libxinerama"
  25. PACKAGECONFIG[xcursor] = "--enable-xcursor,--disable-xcursor,libxcursor"
  26. PACKAGES =+ "${PN}-core ${PN}-lxde ${PN}-gnome ${PN}-config"
  27. PACKAGES_DYNAMIC += "^${PN}-theme-.*"
  28. python populate_packages_prepend() {
  29. theme_dir = d.expand('${datadir}/themes/')
  30. theme_name = d.expand('${PN}-theme-%s')
  31. do_split_packages(d, theme_dir, '(.*)', theme_name, '${PN} theme for %s', extra_depends='', allow_dirs=True)
  32. }
  33. FILES_${PN}-core = "${bindir}/openbox ${bindir}/openbox-session ${libdir}/*${SOLIBS}"
  34. FILES_${PN}-lxde += "${datadir}/lxde/ \
  35. ${datadir}/lxpanel \
  36. ${datadir}/xsessions \
  37. ${datadir}/icons"
  38. FILES_${PN}-gnome += " \
  39. ${bindir}/openbox-gnome-session \
  40. ${datadir}/gnome \
  41. ${datadir}/gnome-session \
  42. "
  43. FILES_${PN}-config += "${sysconfdir}"
  44. RDEPENDS_${PN} += "${PN}-core ${PN}-config ${PN}-theme-clearlooks python python-shell pyxdg"