gimp_2.8.22.bb 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. SUMMARY = "The GIMP is the GNU Image Manipulation Program"
  2. HOMEPAGE = "http://www.gimp.org"
  3. SECTION = "x11/graphics"
  4. LICENSE = "GPLv3"
  5. LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
  6. DEPENDS = " \
  7. gdk-pixbuf-native \
  8. intltool-native \
  9. libxslt-native \
  10. dbus-glib \
  11. gtk+ \
  12. babl \
  13. gegl \
  14. jpeg \
  15. libpng \
  16. libexif \
  17. tiff \
  18. lcms \
  19. poppler \
  20. jasper \
  21. bzip2 \
  22. libgudev \
  23. libmng \
  24. "
  25. DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxmu libxpm', '', d)}"
  26. inherit features_check gnomebase gtk-icon-cache gtk-doc
  27. REQUIRED_DISTRO_FEATURES = "x11"
  28. SRC_URI = "http://ftp.gimp.org/pub/gimp/v2.8/gimp-${PV}.tar.bz2 \
  29. file://0001-configure-ac-do-not-check-for-freetype-config.patch \
  30. file://bump_Babl-GEGL_versions.patch \
  31. file://0003-Fix-use-of-gegl-API.patch \
  32. "
  33. SRC_URI[md5sum] = "7e4fd7a53b1d3c32dff642ab1a94b44d"
  34. SRC_URI[sha256sum] = "9187a35cc52b110d78124d7b27b68a68ade14a794c2721314bac6134d2a5638a"
  35. EXTRA_OECONF = "--disable-python \
  36. --without-webkit \
  37. --without-wmf"
  38. do_configure_append() {
  39. find ${B} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
  40. find ${B} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
  41. }
  42. CFLAGS += "-fPIC"
  43. FILES_${PN}-dbg += "${libdir}/gimp/2.0/*/.debug"
  44. FILES_${PN} += "${datadir}/appdata"