gegl_0.3.18.bb 1.6 KB

12345678910111213141516171819202122232425262728293031323334
  1. SUMMARY = "GEGL (Generic Graphics Library) is a graph based image processing framework"
  2. LICENSE = "LGPL-3.0"
  3. LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
  4. DEPENDS = "babl librsvg glib-2.0 gtk+ pango cairo expat zlib libpng jpeg virtual/libsdl json-glib intltool-native"
  5. EXTRA_OECONF = "--disable-docs"
  6. inherit features_check gnomebase vala gobject-introspection
  7. REQUIRED_DISTRO_FEATURES = "x11"
  8. PACKAGECONFIG ??= ""
  9. PACKAGECONFIG[jasper] = "--with-jasper,--without-jasper,jasper"
  10. PACKAGECONFIG[avformat] = "--with-libavformat,--without-libavformat,libav"
  11. PACKAGECONFIG[lcms] = "--with-lcms,--without-lcms,lcms"
  12. PACKAGECONFIG[tiff] = "--with-libtiff,--without-libtiff,tiff"
  13. PACKAGECONFIG[webp] = "--with-webp,--without-webp,webp"
  14. SRC_URI = "http://ftp.gimp.org/pub/${BPN}/0.3/${BP}.tar.bz2 \
  15. file://pkgconfig.patch "
  16. SRC_URI[md5sum] = "6e5c6f229261478dc436a38c84405b2a"
  17. SRC_URI[sha256sum] = "d7858ef26ede136d14e3de188a9e9c0de7707061a9fb96d7d615fab4958491fb"
  18. LDFLAGS += "-lm"
  19. # There are a couple of non-symlink .so files installed into libdir, which need to go into main package
  20. FILES_${PN}_append = " ${libdir}/gegl-0.3/*.so ${libdir}/gegl-0.3/*.json ${libdir}/libgegl-npd-0.3.so ${libdir}/libgegl-sc-0.3.so"
  21. FILES_${PN}-dev_append = " ${libdir}/gegl-0.3/*.la ${libdir}/libgegl-0.3.so"
  22. FILES_${PN}-dev_remove = "${libdir}/lib*.so"
  23. # Fails to build with thumb-1 (qemuarm)
  24. # gegl-0.2.0/operations/common/matting-global.c: In function 'matting_process':
  25. # gegl-0.2.0/operations/common/matting-global.c:463:1: internal compiler error: in patch_jump_insn, at cfgrtl.c:1275
  26. ARM_INSTRUCTION_SET = "arm"