sblim-sfcb_1.4.9.bb 2.9 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182
  1. SUMMARY = "Small Footprint CIM Broker"
  2. DESCRIPTION = "\
  3. Small Footprint CIM Broker (sfcb) is a CIM server conforming to the CIM \
  4. Operations over HTTP protocol. It is robust, with low resource consumption \
  5. and therefore specifically suited for embedded and resource constrained \
  6. environments. sfcb supports providers written against the Common \
  7. Manageability Programming Interface (CMPI)."
  8. HOMEPAGE = "http://www.sblim.org"
  9. SECTION = "Applications/System"
  10. LICENSE = "EPL-1.0"
  11. LIC_FILES_CHKSUM = "file://COPYING;md5=f300afd598546add034364cd0a533261"
  12. DEPENDS = "curl libpam openssl sblim-sfc-common unzip-native"
  13. inherit features_check
  14. REQUIRED_DISTRO_FEATURES = "pam"
  15. SRC_URI = "http://downloads.sourceforge.net/sblim/${BP}.tar.bz2 \
  16. file://sfcb.service \
  17. file://sblim-sfcb-1.3.9-sfcbrepos-schema-location.patch \
  18. file://sblim-sfcb-1.3.15-fix-provider-debugging.patch \
  19. file://sblim-sfcb-1.3.16-maxMsgLen.patch \
  20. file://sblim-sfcb-1.4.5-service.patch \
  21. file://sblim-sfcb-1.3.16-multilib-man-cfg.patch \
  22. file://sblim-sfcb-1.4.8-default-ecdh-curve-name.patch \
  23. file://sblim-sfcb-1.4.9-fix-ftbfs.patch \
  24. file://0001-include-stdint.h-system-header-for-UINT16_MAX.patch \
  25. file://0001-Replace-need-for-error.h-when-it-does-not-exist.patch \
  26. file://sblim-sfcb-1.4.9-fix-sfcbinst2mof.patch \
  27. "
  28. SRC_URI[md5sum] = "28021cdabc73690a94f4f9d57254ce30"
  29. SRC_URI[sha256sum] = "634a67b2f7ac3b386a79160eb44413d618e33e4e7fc74ae68b0240484af149dd"
  30. inherit autotools
  31. inherit systemd
  32. SYSTEMD_PACKAGES = "${PN}"
  33. SYSTEMD_SERVICE_${PN} = "sblim-sfcb.service"
  34. SYSTEMD_AUTO_ENABLE = "enable"
  35. LDFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
  36. EXTRA_OECONF = '--enable-debug \
  37. --enable-ssl \
  38. --enable-pam \
  39. --enable-ipv6 \
  40. CFLAGS="${CFLAGS} -D_GNU_SOURCE"'
  41. # make all with -j option is unsafe.
  42. PARALLEL_MAKE = ""
  43. INSANE_SKIP_${PN} = "dev-so"
  44. CONFIG_SITE = "${WORKDIR}/config-site.${P}"
  45. do_install() {
  46. cp -f ${S}/sfcb.cfg.pre.in ${S}/sfcb.cfg
  47. oe_runmake DESTDIR=${D} install
  48. install -d ${D}${systemd_unitdir}/system
  49. install -m 0644 ${WORKDIR}/sfcb.service ${D}${systemd_unitdir}/system/sblim-sfcb.service
  50. install -d ${D}${sysconfdir}/init.d
  51. mv ${D}${sysconfdir}/init.d/sfcb ${D}${sysconfdir}/init.d/sblim-sfcb
  52. sed -i -e 's/\/var\/lock\/subsys\/sfcb/\/var\/lock\/subsys\/sblim-sfcb/g' ${D}${sysconfdir}/init.d/sblim-sfcb
  53. rm -rf ${D}${libdir}/sfcb/*.la
  54. }
  55. pkg_postinst_${PN} () {
  56. if [ x"$D" != "x" ]; then
  57. $INTERCEPT_DIR/postinst_intercept delay_to_first_boot ${PKG} mlprefix=${MLPREFIX}
  58. fi
  59. ${datadir}/sfcb/genSslCert.sh ${sysconfdir}/sfcb
  60. ${bindir}/sfcbrepos -f
  61. }
  62. FILES_${PN} += "${libdir}/sfcb ${datadir}/sfcb"
  63. FILES_${PN}-dbg += "${libdir}/sfcb/.debug"
  64. RDEPENDS_${PN} = "perl bash"