polkit_0.116.bb 2.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. SUMMARY = "PolicyKit Authorization Framework"
  2. DESCRIPTION = "The polkit package is an application-level toolkit for defining and handling the policy that allows unprivileged processes to speak to privileged processes."
  3. HOMEPAGE = "http://www.freedesktop.org/wiki/Software/polkit"
  4. LICENSE = "LGPLv2+"
  5. LIC_FILES_CHKSUM = "file://COPYING;md5=155db86cdbafa7532b41f390409283eb \
  6. file://src/polkit/polkit.h;beginline=1;endline=20;md5=0a8630b0133176d0504c87a0ded39db4"
  7. DEPENDS = "expat glib-2.0 intltool-native mozjs"
  8. inherit autotools gtk-doc pkgconfig useradd systemd gobject-introspection features_check
  9. REQUIRED_DISTRO_FEATURES = "polkit"
  10. PACKAGECONFIG = "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)} \
  11. ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', \
  12. bb.utils.contains('DISTRO_FEATURES', 'x11', 'consolekit', '', d), d)} \
  13. "
  14. PACKAGECONFIG[pam] = "--with-authfw=pam,--with-authfw=shadow,libpam,libpam"
  15. PACKAGECONFIG[systemd] = "--enable-libsystemd-login=yes --with-systemdsystemunitdir=${systemd_unitdir}/system/,--enable-libsystemd-login=no --with-systemdsystemunitdir=,systemd"
  16. # there is no --enable/--disable option for consolekit and it's not picked by shlibs, so add it to RDEPENDS
  17. PACKAGECONFIG[consolekit] = ",,,consolekit"
  18. PAM_SRC_URI = "file://polkit-1_pam.patch"
  19. SRC_URI = "http://www.freedesktop.org/software/polkit/releases/polkit-${PV}.tar.gz \
  20. ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)} \
  21. file://0003-make-netgroup-support-optional.patch \
  22. "
  23. SRC_URI[md5sum] = "4b37258583393e83069a0e2e89c0162a"
  24. SRC_URI[sha256sum] = "88170c9e711e8db305a12fdb8234fac5706c61969b94e084d0f117d8ec5d34b1"
  25. EXTRA_OECONF = "--with-os-type=moblin \
  26. --disable-man-pages \
  27. --disable-libelogind \
  28. "
  29. do_compile_prepend () {
  30. export GIR_EXTRA_LIBS_PATH="${B}/src/polkit/.libs"
  31. }
  32. PACKAGES =+ "${PN}-examples"
  33. FILES_${PN}_append = " \
  34. ${libdir}/${BPN}-1 \
  35. ${nonarch_libdir}/${BPN}-1 \
  36. ${datadir}/dbus-1 \
  37. ${datadir}/${BPN}-1 \
  38. ${datadir}/gettext \
  39. "
  40. FILES_${PN}-examples = "${bindir}/*example*"
  41. USERADD_PACKAGES = "${PN}"
  42. USERADD_PARAM_${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/${BPN}-1 polkitd"
  43. SYSTEMD_SERVICE_${PN} = "${BPN}.service"
  44. SYSTEMD_AUTO_ENABLE = "disable"