pam-ssh-agent-auth_0.10.3.bb 2.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. SUMMARY = "pam-ssh-agent-auth"
  2. DESCRIPTION = "A PAM module which permits authentication via ssh-agent."
  3. HOMEPAGE = "http://sourceforge.net/projects/pamsshagentauth/"
  4. SECTION = "libs"
  5. LICENSE = "openssl & BSD"
  6. LIC_FILES_CHKSUM = "file://LICENSE.OpenSSL;md5=8ab01146141ded59b75f8ba7811ed05a \
  7. file://OPENSSH_LICENSE;md5=7ae09218173be1643c998a4b71027f9b \
  8. "
  9. SRC_URI = "http://sourceforge.net/projects/pamsshagentauth/files/pam_ssh_agent_auth/v${PV}/pam_ssh_agent_auth-${PV}.tar.bz2 \
  10. file://0001-Adapt-to-OpenSSL-1.1.1.patch \
  11. file://0002-Check-against-the-correct-OPENSSL_VERSION_NUMBER.patch \
  12. "
  13. SRC_URI[md5sum] = "8dbe90ab3625e545036333e6f51ccf1d"
  14. SRC_URI[sha256sum] = "3c53d358d6eaed1b211239df017c27c6f9970995d14102ae67bae16d4f47a763"
  15. DEPENDS += "libpam openssl"
  16. inherit features_check
  17. REQUIRED_DISTRO_FEATURES = "pam"
  18. # This gets us ssh-agent, which we are almost certain to want.
  19. #
  20. RDEPENDS_${PN} += "openssh-misc"
  21. # Kind of unfortunate to have underscores in the name.
  22. #
  23. S = "${WORKDIR}/pam_ssh_agent_auth-${PV}"
  24. inherit autotools-brokensep
  25. # Avoid autoreconf. Override the --libexec oe_runconf specifies so that
  26. # the module is put with the other pam modules. Because it cannot, in general,
  27. # do a runtime test, configure wants to use rpl_malloc() and rpl_realloc()
  28. # instead of malloc() and realloc(). We set variables to tell it not to because
  29. # these functions do not exist.
  30. #
  31. do_configure () {
  32. install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}
  33. install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}
  34. oe_runconf --without-openssl-header-check --libexecdir=${base_libdir}/security \
  35. ac_cv_func_malloc_0_nonnull=yes ac_cv_func_realloc_0_nonnull=yes
  36. }
  37. # Link with CC. Configure cannot figure out the correct AR.
  38. #
  39. do_compile () {
  40. oe_runmake LD="${CC}" AR="${AR}"
  41. }
  42. # This stuff is not any place looked at by default.
  43. #
  44. FILES_${PN} += "${base_libdir}/security/pam*"
  45. FILES_${PN}-dbg += "${base_libdir}/security/.debug"