openwsman_2.6.11.bb 2.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172
  1. SUMMARY = "Opensource Implementation of WS-Management"
  2. DESCRIPTION = "Openwsman is a project intended to provide an open-source \
  3. implementation of the Web Services Management specipication \
  4. (WS-Management) and to expose system management information on the \
  5. Linux operating system using the WS-Management protocol. WS-Management \
  6. is based on a suite of web services specifications and usage \
  7. requirements that exposes a set of operations focused on and covers \
  8. all system management aspects. \
  9. Openwsman Server and service libraries"
  10. HOMEPAGE = "http://www.openwsman.org/"
  11. SECTION = "Applications/System"
  12. DEPENDS = "curl libxml2 openssl libpam"
  13. inherit features_check
  14. REQUIRED_DISTRO_FEATURES = "pam"
  15. SRCREV = "d8eba6cb6682b59d84ca1da67a523520b879ade6"
  16. SRC_URI = "git://github.com/Openwsman/openwsman.git \
  17. file://libssl-is-required-if-eventint-supported.patch \
  18. file://openwsmand.service \
  19. file://0001-lock.c-Define-PTHREAD_MUTEX_RECURSIVE_NP-if-undefine.patch \
  20. "
  21. S = "${WORKDIR}/git"
  22. LICENSE = "BSD-3-Clause"
  23. LIC_FILES_CHKSUM = "file://COPYING;md5=d4f53d4c6cf73b9d43186ce3be6dd0ba"
  24. inherit systemd cmake pkgconfig python3native perlnative
  25. SYSTEMD_SERVICE_${PN} = "openwsmand.service"
  26. SYSTEMD_AUTO_ENABLE = "disable"
  27. LDFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', " -fuse-ld=bfd ", '', d)}"
  28. EXTRA_OECMAKE = "-DBUILD_BINDINGS=NO \
  29. -DBUILD_LIBCIM=NO \
  30. -DBUILD_PERL=YES \
  31. -DBUILD_PYTHON3=YES \
  32. -DBUILD_PYTHON=NO \
  33. -DCMAKE_INSTALL_PREFIX=${prefix} \
  34. -DLIB=${baselib} \
  35. "
  36. do_configure_prepend() {
  37. export STAGING_INCDIR=${STAGING_INCDIR}
  38. export STAGING_LIBDIR=${STAGING_LIBDIR}
  39. }
  40. do_install_append() {
  41. install -d ${D}/${sysconfdir}/init.d
  42. install -m 755 ${B}/etc/init/openwsmand.sh ${D}/${sysconfdir}/init.d/openwsmand
  43. ln -sf ${sysconfdir}/init.d/openwsmand ${D}/${sbindir}/rcopenwsmand
  44. chmod 755 ${D}/${sysconfdir}/openwsman/owsmangencert.sh
  45. if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
  46. install -d ${D}/${systemd_unitdir}/system
  47. install -m 644 ${WORKDIR}/openwsmand.service ${D}/${systemd_unitdir}/system
  48. sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/openwsmand.service
  49. sed -i -e 's,@SYSCONFDIR@,${sysconfdir},g' ${D}${systemd_unitdir}/system/openwsmand.service
  50. sed -i -e 's,@LOCALSTATEDIR@,${localstatedir},g' ${D}${systemd_unitdir}/system/openwsmand.service
  51. fi
  52. }
  53. FILES_${PN}-dbg += "${libdir}/openwsman/plugins/.debug/ \
  54. ${libdir}/openwsman/authenticators/.debug/ \
  55. "
  56. INSANE_SKIP_${PN} = "dev-so"
  57. RDEPENDS_${PN} = "ruby"