libreport_2.10.0.bb 1.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. DESCRIPTION = "Libraries providing API for reporting different problems in applications \
  2. to different bug targets like Bugzilla, ftp, trac, etc..."
  3. SUMMARY = "Generic library for reporting various problems"
  4. HOMEPAGE = "https://abrt.readthedocs.org/"
  5. LICENSE = "GPLv2+"
  6. DEPENDS = "xmlrpc-c xmlrpc-c-native intltool-native \
  7. json-c libtar libnewt libproxy rpm \
  8. augeas satyr systemd \
  9. "
  10. LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
  11. SRC_URI = "git://github.com/abrt/libreport.git;protocol=https"
  12. SRC_URI += "file://0001-Makefile.am-remove-doc-and-apidoc.patch \
  13. file://0002-configure.ac-remove-prog-test-of-xmlto-and-asciidoc.patch \
  14. file://0003-without-build-plugins.patch \
  15. file://0004-configure.ac-remove-prog-test-of-augparse.patch \
  16. "
  17. SRCREV = "eaff08f38d771d9362923765bb404b1514c5ca0a"
  18. UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
  19. S = "${WORKDIR}/git"
  20. inherit features_check
  21. REQUIRED_DISTRO_FEATURES = "systemd"
  22. inherit gettext autotools python3native pkgconfig
  23. PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES','x11','gtk','',d)}"
  24. PACKAGECONFIG[gtk] = "--with-gtk, --without-gtk, gtk+3,"
  25. EXTRA_OECONF += "--without-python2 --with-python3"
  26. RDEPENDS_python3-libreport += "${PN}"
  27. do_patch[prefuncs] += "do_gen_version"
  28. do_gen_version() {
  29. cd ${S}
  30. ./gen-version
  31. }
  32. PACKAGES += "python3-libreport"
  33. FILES_${PN} += "${datadir}/*"
  34. FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/*/.debug"
  35. FILES_python3-libreport = "${PYTHON_SITEPACKAGES_DIR}/*"