dante_1.4.1.bb 1.7 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. SECTION = "console/utils"
  2. SUMMARY = "A free SOCKS server"
  3. DESCRIPTION = "Dante consists of a SOCKS server and a SOCKS client,\
  4. implementing RFC 1928 and related standards. It is a flexible product\
  5. that can be used to provide convenient and secure network\
  6. connectivity. Once installed, Dante can in most cases be made\
  7. transparent to clients, providing functionality somewhat similar to\
  8. what could be described as a non-transparent Layer 4 router."
  9. HOMEPAGE = "http://www.inet.no/dante/"
  10. LICENSE = "BSD-3-Clause"
  11. LIC_FILES_CHKSUM = "file://LICENSE;md5=221118dda731fe93a85d0ed973467249"
  12. SRC_URI = "https://www.inet.no/dante/files/dante-${PV}.tar.gz \
  13. "
  14. SRC_URI[md5sum] = "68c2ce12119e12cea11a90c7a80efa8f"
  15. SRC_URI[sha256sum] = "b6d232bd6fefc87d14bf97e447e4fcdeef4b28b16b048d804b50b48f261c4f53"
  16. # without --without-gssapi, config.log will contain reference to /usr/lib
  17. # as a consequence of GSSAPI path being set to /usr by default.
  18. # --with-gssapi-path=PATH specify gssapi path
  19. # --without-gssapi disable gssapi support
  20. # --enable-release build prerelease as full release
  21. EXTRA_OECONF += "--without-gssapi --sbindir=${bindir}"
  22. DEPENDS += "flex-native bison-native libpam"
  23. inherit autotools-brokensep features_check
  24. REQUIRED_DISTRO_FEATURES = "pam"
  25. EXTRA_AUTORECONF = "-I ${S}"
  26. PACKAGECONFIG[libwrap] = ",--disable-libwrap,tcp-wrappers,libwrap"
  27. PACKAGECONFIG[krb5] = ",--without-krb5,krb5"
  28. PACKAGECONFIG ??= ""
  29. do_install_append() {
  30. install -d ${D}${sysconfdir}
  31. cp ${S}/example/sock[sd].conf ${D}${sysconfdir}
  32. }
  33. PACKAGES =+ "${PN}-sockd ${PN}-libdsocks "
  34. FILES_${PN}-libdsocks = "${libdir}/libdsocks.so"
  35. FILES_${PN}-sockd = "${bindir}/sockd ${sysconfdir}/sockd.conf"
  36. INSANE_SKIP_${PN}-libdsocks = "dev-elf"