vlc_3.0.8.bb 5.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125
  1. DESCRIPTION = "Video player and streamer - davinci edition"
  2. HOMEPAGE = "http://www.videolan.org"
  3. SECTION = "multimedia"
  4. LICENSE = "GPL-2.0"
  5. LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
  6. DEPENDS = "coreutils-native fribidi libtool libgcrypt libgcrypt-native \
  7. dbus libxml2 gnutls \
  8. tremor faad2 ffmpeg flac fluidsynth alsa-lib \
  9. lua-native lua libidn \
  10. avahi jpeg xz libmodplug mpeg2dec \
  11. libmtp libopus orc libsamplerate0 libusb1 schroedinger taglib \
  12. tiff"
  13. # While this item does not require it, it depends on ffmpeg which does
  14. LICENSE_FLAGS = "commercial"
  15. SRC_URI = "http://download.videolan.org/pub/videolan/${BPN}/${PV}/${BP}.tar.xz \
  16. file://0006-make-opencv-configurable.patch \
  17. file://0007-use-vorbisidec.patch \
  18. file://0008-fix-luaL-checkint.patch \
  19. "
  20. SRC_URI[md5sum] = "744442ec0c145453ea1d257914c8072e"
  21. SRC_URI[sha256sum] = "e0149ef4a20a19b9ecd87309c2d27787ee3f47dfd47c6639644bc1f6fd95bdf6"
  22. inherit autotools gettext pkgconfig features_check
  23. ARM_INSTRUCTION_SET = "arm"
  24. export BUILDCC = "${BUILD_CC}"
  25. EXTRA_OECONF = "\
  26. --enable-run-as-root \
  27. --enable-xvideo \
  28. --disable-screen --disable-caca \
  29. --enable-vlm \
  30. --enable-freetype \
  31. --enable-tremor \
  32. --enable-v4l2 --disable-aa --disable-faad \
  33. --enable-dbus \
  34. --without-contrib \
  35. --without-kde-solid \
  36. --enable-realrtsp \
  37. --disable-libtar \
  38. --enable-avcodec \
  39. ac_cv_path_MOC=${STAGING_BINDIR_NATIVE}${QT_DIR_NAME}/moc \
  40. ac_cv_path_RCC=${STAGING_BINDIR_NATIVE}${QT_DIR_NAME}/rcc \
  41. ac_cv_path_UIC=${STAGING_BINDIR_NATIVE}${QT_DIR_NAME}/uic \
  42. "
  43. PACKAGECONFIG ?= " \
  44. live555 dc1394 dv1394 notify fontconfig freetype dvdread png \
  45. ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \
  46. "
  47. inherit ${@bb.utils.contains('PACKAGECONFIG', 'qt5', 'qmake5_paths', '', d)}
  48. PACKAGECONFIG[mad] = "--enable-mad,--disable-mad,libmad"
  49. PACKAGECONFIG[a52] = "--enable-a52,--disable-a52,liba52"
  50. PACKAGECONFIG[jack] = "--enable-jack,--disable-jack,jack"
  51. PACKAGECONFIG[live555] = "--enable-live555 LIVE555_PREFIX=${STAGING_DIR_HOST}${prefix},--disable-live555,live555"
  52. PACKAGECONFIG[libass] = "--enable-libass,--disable-libass,libass"
  53. PACKAGECONFIG[postproc] = "--enable-postproc,--disable-postproc,libpostproc"
  54. PACKAGECONFIG[libva] = "--enable-libva,--disable-libva,libva"
  55. PACKAGECONFIG[opencv] = "--enable-opencv,--disable-opencv,opencv"
  56. PACKAGECONFIG[speex] = "--enable-speex,--disable-speex,speex"
  57. PACKAGECONFIG[gstreamer] = "--enable-gst-decode,--disable-gst-decode,gstreamer1.0 gstreamer1.0-plugins-base gst-plugins-bad"
  58. PACKAGECONFIG[vpx] = "--enable-vpx,--disable-vpx, libvpx"
  59. PACKAGECONFIG[qt5] = "--enable-qt,--disable-qt, qtbase-native qtx11extras qtsvg"
  60. PACKAGECONFIG[freerdp] = "--enable-freerdp,--disable-freerdp, freerdp"
  61. PACKAGECONFIG[dvbpsi] = "--enable-dvbpsi,--disable-dvbpsi, libdvbpsi"
  62. PACKAGECONFIG[samba] = "--enable-smbclient,--disable-smbclient, samba"
  63. PACKAGECONFIG[upnp] = "--enable-upnp,--disable-upnp,libupnp"
  64. PACKAGECONFIG[dvdnav] = "--enable-dvdnav,--disable-dvdnav,libdvdnav libdvdcss"
  65. PACKAGECONFIG[sftp] = "--enable-sftp,--disable-sftp,libssh2"
  66. PACKAGECONFIG[vorbis] = "--enable-vorbis,--disable-vorbis,libvorbis libogg"
  67. PACKAGECONFIG[ogg] = "--enable-ogg,--disable-ogg,libvorbis libogg"
  68. PACKAGECONFIG[dc1394] = "--enable-dc1394,--disable-dc1394,libdc1394"
  69. PACKAGECONFIG[dv1394] = "--enable-dv1394,--disable-dv1394,libraw1394 libavc1394"
  70. PACKAGECONFIG[svg] = "--enable-svg,--disable-svg,librsvg"
  71. PACKAGECONFIG[svgdec] = "--enable-svgdec,--disable-svgdec,librsvg cairo"
  72. PACKAGECONFIG[notify] = "--enable-notify,--disable-notify, libnotify gtk+3"
  73. PACKAGECONFIG[fontconfig] = "--enable-fontconfig,--disable-fontconfig, fontconfig"
  74. PACKAGECONFIG[freetype] = "--enable-freetype,--disable-freetype, freetype"
  75. PACKAGECONFIG[dvdread] = "--enable-dvdread,--disable-dvdread, libdvdread libdvdcss"
  76. PACKAGECONFIG[vnc] = "--enable-vnc,--disable-vnc, libvncserver"
  77. PACKAGECONFIG[x11] = "--with-x --enable-xcb,--without-x --disable-xcb, xcb-util-keysyms libxpm libxinerama"
  78. PACKAGECONFIG[png] = "--enable-png,--disable-png,libpng"
  79. PACKAGECONFIG[vdpau] = "--enable-vdpau,--disable-vdpau,libvdpau"
  80. do_configure_append() {
  81. sed -i -e s:'${top_builddir_slash}libtool':'${top_builddir_slash}'${TARGET_SYS}-libtool:g ${B}/doltlibtool
  82. # moc needs support: precreate build paths
  83. for qtpath in adapters components/epg components/playlist components/sout dialogs managers styles util/buttons; do
  84. mkdir -p "${B}/modules/gui/qt/$qtpath"
  85. done
  86. }
  87. # This recipe packages vlc as a library as well, so qt4 dependencies
  88. # can be avoided when only the library is installed.
  89. PACKAGES =+ "libvlc"
  90. LEAD_SONAME_libvlc = "libvlc.so.5"
  91. FILES_libvlc = "${libdir}/lib*.so.*"
  92. FILES_${PN} += "\
  93. ${bindir}/vlc \
  94. ${libdir}/vlc/vlc/libvlc_vdpau.so \
  95. ${datadir}/applications \
  96. ${datadir}/vlc/ \
  97. ${datadir}/icons \
  98. ${datadir}/metainfo/vlc.appdata.xml \
  99. "
  100. FILES_${PN}-dbg += "\
  101. ${libdir}/vlc/*/.debug \
  102. ${libdir}/vlc/plugins/*/.debug \
  103. "
  104. FILES_${PN}-staticdev += "\
  105. ${libdir}/vlc/plugins/*/*.a \
  106. "
  107. INSANE_SKIP_${PN} = "dev-so"