capnproto_0.8.0.bb 810 B

1234567891011121314151617181920212223242526
  1. SUMMARY = "Cap'n Proto serialization/RPC system"
  2. DESCRIPTION = "Cap’n Proto is an insanely fast data interchange format and capability-based RPC system. "
  3. HOMEPAGE = "https://github.com/sandstorm-io/capnproto"
  4. SECTION = "console/tools"
  5. LICENSE = "MIT"
  6. LIC_FILES_CHKSUM = "file://../LICENSE;md5=a05663ae6cca874123bf667a60dca8c9"
  7. SRC_URI = "git://github.com/sandstorm-io/capnproto.git;branch=release-${PV} \
  8. file://0001-mutex-Fix-build-on-32-bit-architectures-using-64-bit.patch;patchdir=../ \
  9. "
  10. SRCREV = "57a4ca5af5a7f55b768a9d9d6655250bffb1257f"
  11. S = "${WORKDIR}/git/c++"
  12. inherit cmake
  13. EXTRA_OECMAKE += "\
  14. -DBUILD_TESTING=OFF \
  15. "
  16. FILES_${PN}-compiler = "${bindir}"
  17. PACKAGE_BEFORE_PN = "${PN}-compiler"
  18. RDEPENDS_${PN}-dev += "${PN}-compiler"
  19. BBCLASSEXTEND = "native nativesdk"