paho-mqtt-c_1.3.8.bb 1.0 KB

12345678910111213141516171819202122232425262728293031323334
  1. SUMMARY = "Paho MQTT - C libraries for the MQTT and MQTT-SN protocols"
  2. DESCRIPTION = "Client implementation of open and standard messaging protocols for Machine-to-Machine (M2M) and Internet of Things (IoT)."
  3. HOMEPAGE = "http://www.eclipse.org/paho/"
  4. SECTION = "console/network"
  5. LICENSE = "EPL-2.0 | EDL-1.0"
  6. LIC_FILES_CHKSUM = " \
  7. file://edl-v10;md5=3adfcc70f5aeb7a44f3f9b495aa1fbf3 \
  8. file://epl-v20;md5=d9fc0efef5228704e7f5b37f27192723 \
  9. file://notice.html;md5=943f861069889acecebf51dfa24478e2 \
  10. file://about.html;md5=e5662cbb5f8fd5c9faac526e4077898e \
  11. "
  12. SRC_URI = "git://github.com/eclipse/paho.mqtt.c;protocol=http"
  13. SRCREV = "317fb008e1541838d1c29076d2bc5c3e4b6c4f53"
  14. DEPENDS = "openssl"
  15. S = "${WORKDIR}/git"
  16. inherit cmake
  17. do_configure_prepend() {
  18. sed -i s:\ lib/cmake:\ ${baselib}/cmake:g ${S}/src/CMakeLists.txt
  19. }
  20. do_install_append() {
  21. # paho-mqtt installes some thing that we don't want.
  22. rm -rf ${D}${prefix}/samples
  23. find ${D}${prefix} -maxdepth 1 -type f -delete
  24. }
  25. EXTRA_OECMAKE = "-DPAHO_WITH_SSL=ON"