fcgiwrap_git.bb 761 B

123456789101112131415161718192021222324
  1. SUMMARY = "FastCGI wrapper for CGI scripts"
  2. DESCRIPTION = "FcgiWrap is a simple server for running CGI applications over FastCGI. Fcgiwrap can be used together with Nginx to serve CGI or Perl scripts"
  3. HOMEPAGE = "https://github.com/gnosek/fcgiwrap"
  4. LICENSE = "MIT"
  5. LIC_FILES_CHKSUM = "file://COPYING;md5=a95d02d614a3a0232d4e6e51b7963c5b"
  6. DEPENDS = "fcgi"
  7. SRC_URI = "git://github.com/gnosek/fcgiwrap.git;protocol=https;branch=${BRANCH} \
  8. file://0001-Fix-implicit-fallthrough-warning.patch \
  9. "
  10. BRANCH = "master"
  11. SRCREV = "99c942c90063c73734e56bacaa65f947772d9186"
  12. S = "${WORKDIR}/git"
  13. CFLAGS =+ "-I${B}"
  14. EXTRA_OEMAKE = "VPATH=${S}"
  15. inherit autotools pkgconfig
  16. do_install() {
  17. install -Dm 755 ${B}/fcgiwrap ${D}${sbindir}/fcgiwrap
  18. }