firmwared_git.bb 1.0 KB

12345678910111213141516171819202122232425262728293031323334
  1. SUMMARY = "Linux Firmware Loader Daemon"
  2. DESCRIPTION = "The Linux Firmware Loader Daemon monitors the kernel for \
  3. firmware requests and uploads the firmware blobs it has via the sysfs \
  4. interface."
  5. HOMEPAGE = "https://github.com/teg/firmwared"
  6. LICENSE = "Apache-2.0"
  7. LIC_FILES_CHKSUM = "file://LICENSE-APACHE;md5=7b486c2338d225a1405d979ed2c15ce8 \
  8. file://COPYING;md5=daa868b8e1ae17d03228a1145b4060da"
  9. SRC_URI = "git://github.com/teg/firmwared.git \
  10. file://firmwared.service"
  11. PV = "0+git${SRCPV}"
  12. SRCREV = "2e6b5db43d63a5c0283a4cae9a6a20b7ad107a04"
  13. S = "${WORKDIR}/git"
  14. DEPENDS = "glib-2.0 systemd"
  15. inherit pkgconfig autotools systemd features_check
  16. REQUIRED_DISTRO_FEATURES = "systemd"
  17. SYSTEMD_SERVICE_${PN} = "firmwared.service"
  18. do_configure_prepend() {
  19. ${S}/autogen.sh
  20. }
  21. do_install_append() {
  22. install -d ${D}${systemd_system_unitdir}
  23. install -m 0644 ${WORKDIR}/firmwared.service ${D}${systemd_system_unitdir}
  24. sed -i -e 's,@BINDIR@,${bindir},g' ${D}${systemd_system_unitdir}/firmwared.service
  25. }