tesseract-lang_git.bb 868 B

1234567891011121314151617181920212223242526
  1. SUMMARY = "tesseract-ocr language files"
  2. LICENSE = "Apache-2.0"
  3. LIC_FILES_CHKSUM = "file://COPYING;md5=9648bd7af63bd3cc4f5ac046d12c49e4"
  4. PV = "3.04.00+git${SRCPV}"
  5. SRCREV = "3cf1e2df1fe1d1da29295c9ef0983796c7958b7d"
  6. SRC_URI = "git://github.com/tesseract-ocr/tessdata.git"
  7. S = "${WORKDIR}/git"
  8. inherit allarch
  9. do_install() {
  10. install -d ${D}${datadir}/tessdata
  11. cp -R --no-dereference --preserve=mode,links -v ${S}/*.traineddata ${S}/*.cube.* ${S}/*.tesseract_cube.* ${D}${datadir}/tessdata
  12. }
  13. python populate_packages_prepend () {
  14. tessdata_dir= d.expand('${datadir}/tessdata')
  15. pkgs = do_split_packages(d, tessdata_dir, '^([a-z_]*)\.*', '${BPN}-%s', 'tesseract-ocr language files for %s', extra_depends='')
  16. pn = d.getVar('PN', True)
  17. d.appendVar('RDEPENDS_' + pn, ' '+' '.join(pkgs))
  18. }
  19. PACKAGES_DYNAMIC += "^${BPN}-.*"
  20. ALLOW_EMPTY_${PN} = "1"