start-stop-daemon_1.16.0.2.bb 1016 B

12345678910111213141516171819202122232425262728293031
  1. SUMMARY = "Debian's start-stop-daemon utility extracted from the dpkg \
  2. package"
  3. LICENSE = "PD"
  4. LIC_FILES_CHKSUM = "file://utils/start-stop-daemon.c;md5=a963623e4588f70122865aaa7a370ce4"
  5. # start-stop-daemon is usually shipped by dpkg
  6. DEPENDS = "ncurses"
  7. RCONFLICS_${PN} = "dpkg"
  8. SRC_URI = "http://sources.openembedded.org/dpkg_${PV}.tar.bz2"
  9. SRC_URI[md5sum] = "d211a84f38987771a49ad1c0f144334a"
  10. SRC_URI[sha256sum] = "2a3d4ba83c743b3f004533fdd52372cb7b22f5c1da2042d0a31bbcc2b54c0ea5"
  11. inherit autotools gettext pkgconfig
  12. S = "${WORKDIR}/dpkg-${PV}"
  13. EXTRA_OECONF = " \
  14. --with-start-stop-daemon \
  15. --without-bz2 \
  16. --without-deselect \
  17. --without-install-info \
  18. --without-selinux \
  19. --without-update-alternatives \
  20. "
  21. do_install_append () {
  22. # remove everything that is not related to start-stop-daemon, since there
  23. # is no explicit rule for only installing ssd
  24. find ${D} -type f -not -name "*start-stop-daemon*" -exec rm {} \;
  25. find ${D} -depth -type d -empty -exec rmdir {} \;
  26. }